Bug 55102 - Forced emacs mode
Summary: Forced emacs mode
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-25 16:17 UTC by Nadav Har'El
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 16:17:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nadav Har'El 2001-10-25 16:17:20 UTC
You put in /etc/zshrc the line
           bindkey -e

Which forces emacs mode. Why? The default zsh behavior already defaults to
emacs, unless the user uses either bindkey -v or sets EDITOR or VISUAL to
vi (or vi's full pathname). But because of that line you put in /etc/zshrc,
setting VISUAL in .zprofile no longer works as explained in the manual (and
as it used to), and now I'm forced to use "bindkey -v" in my own .zshrc.

I think that this arms-race is not very useful, and it is better if
Redhat's configuration don't try to enforce emacs mode...

Comment 1 Trond Eivind Glomsrxd 2001-10-26 16:04:28 UTC
Commented the line in 4.0.4-1 - as long as it's the default, there's no reason
to set it explicitly. It's just been there for a long time.


Note You need to log in before you can comment on or make changes to this bug.