Bug 551024 - [abrt] crash detected in calibre-0.6.26-1.fc12 (custom pyPdf)
Summary: [abrt] crash detected in calibre-0.6.26-1.fc12 (custom pyPdf)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5820074b
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-28 14:59 UTC by Antonio
Modified: 2010-06-21 13:12 UTC (History)
5 users (show)

Fixed In Version: calibre-0.6.55-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-21 13:12:18 UTC


Attachments (Terms of Use)
File: backtrace (673 bytes, text/plain)
2009-12-28 14:59 UTC, Antonio
no flags Details

Description Antonio 2009-12-28 14:59:52 UTC
abrt 1.0.0 detected a crash.

backtrace
-----
Summary: TB5820074b writer.py:141:_write:TypeError: __init__() got an unexpected keyword argument 'title'

Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 130, in _render_html
    self._render_book()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 105, in _render_book
    self._write()
  File "/usr/lib/calibre/calibre/ebooks/pdf/writer.py", line 141, in _write
    outPDF = PdfFileWriter(title=self.metadata.title, author=self.metadata.author)
TypeError: __init__() got an unexpected keyword argument 'title'

Local variables in innermost frame:
self: <calibre.ebooks.pdf.writer.PDFWriter object at 0xa91056c>

cmdline: python /usr/bin/calibre-parallel 
component: calibre
executable: /usr/bin/calibre-parallel
kernel: 2.6.31.6-166.fc12.i686
package: calibre-0.6.26-1.fc12
uuid: 5820074b

Comment 1 Antonio 2009-12-28 14:59:54 UTC
Created attachment 380639 [details]
File: backtrace

Comment 2 Ionuț Arțăriși 2010-02-07 13:32:46 UTC
Thanks for reporting this, Antonio.

This seems to be caused by calibre shipping with their own modified version of pyPdf.

Comment 3 Luis Garza 2010-04-13 21:09:58 UTC

How to reproduce
-----
1. tried to convert an epub to pdf
2.
3.

Comment 4 Luis Garza 2010-04-13 21:12:26 UTC

How to reproduce
-----
1. tried to convert an rtf to a pdf
2.
3.


Comment
-----
Just try to convert an rtf or epub file to pdf...seems like it's actually anything-to-pdf that is crashing, so...it'd probably be the pdf creating parts.

Comment 5 Fedora Admin XMLRPC Client 2010-05-13 04:25:42 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Kevin Fenzi 2010-05-23 20:58:35 UTC
Greetings.

I have created a test build of the latest calibre version for Fedora 12.

Can you please update from:             
http://koji.fedoraproject.org/koji/taskinfo?taskID=2204259

And see if you can reproduce this bug?

Comment 7 Fedora Update System 2010-05-29 22:15:11 UTC
calibre-0.6.55-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/calibre-0.6.55-1.fc12

Comment 8 Fedora Update System 2010-05-31 18:14:11 UTC
calibre-0.6.55-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update calibre'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/calibre-0.6.55-1.fc12

Comment 9 Tanay Goel 2010-06-11 17:52:03 UTC
Package: calibre-0.6.42-1.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


Comment
-----
Calibre was trying to convert an .epub book to .pdf. After reporting that the conversion has been successfully completed, it crashed. Also, the resulting .pdf file was of 0 bytes size.

Comment 10 Kevin Fenzi 2010-06-11 18:39:16 UTC
Please test the version in updates-testing?

Comment 11 David Webb 2010-06-18 08:21:59 UTC
Package: calibre-0.6.42-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. converting ebook with PNG image as cover.
2.
3.

Comment 12 Fedora Update System 2010-06-21 13:10:44 UTC
calibre-0.6.55-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.