Bug 551191 - preserve NumLock & CapsLock leds at X Server startup.
preserve NumLock & CapsLock leds at X Server startup.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-keyboard (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
: Patch, Triaged
Depends On:
Blocks: 502912 590060 743405 1002709
  Show dependency treegraph
 
Reported: 2009-12-29 07:39 EST by ritz
Modified: 2013-10-06 21:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2009-12-29 07:39:07 EST
Description of problem:
NumLock & CapsLock status is not prevered at X Server startup.

Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.1.0-3

How reproducible:
always

Steps to Reproduce:
1. INITTY=/dev/tty[1-8]
2. for tty in $INITTY; do setleds -D +num < $tty;done 
3. xinit
  
Actual results:
NumLock is off

Expected results:
NumLock should be on

Additional info:
Patch from upstream, applies directly to package.
http://cgit.freedesktop.org/xorg/driver/xf86-input-keyboard/patch/?id=0382ed1c0c29ee19cfa8bff213ee32a7d0c06da9
Comment 2 RHEL Product and Program Management 2010-08-09 15:29:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-05-31 10:57:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2012-06-11 21:20:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 Andrius Benokraitis 2013-10-06 21:44:38 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.