Bug 55120 - ifup ppp0 Connection times out
ifup ppp0 Connection times out
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 16:06 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 16:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-25 16:06:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en]C-CCK-MCD BA45DSL  (Win98; U)

Description of problem:
redhat 7.2 server install, hand-installed gnome packages, set up eth1 to come up wihtout IP, set up DSL (which is Verizon's, with WinPoet on Windows 
box) 
with internet-druid (xDSL, eth1, Provider: Verizon, Login: myloginname, Password: mypassword).  Then ifup eth1 (works), ifup ppp0 (about ten periods, 
then TIMEOUT).  Tried using 'myloginname@verizon.net' in ifcfg-ppp0 and still no luck.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Redhat Linux 7.2, server install, with Gnome, config eth1 without IP
2. run internet-druid, set up xDSL
3. ifup eth1, ifup ppp0
	

Actual Results:  # adsl-start eth1 myusername /etc/sysconfig/network-scripts/ifcfg-ppp0
...........TIIMED OUT
/usr/sbin/adsl-start: line 191: 19499 Terminated                    $CONNECT "$@" >/dev/null 2>&1
(and tcpdump eth1 says):
# tcpdump -i eth1
tcpdump: WARNING: eth1: no IPv4 address assigned
tcpdump: listening on eth1
tcpdump: pcap_loop: recvfrom: Network is down
# tcpdump -i eth1
12:43:02.055336 PPPoE PADI [Service-Name] [Host-Uniq UTF8]

Expected Results:  A successful connection leading to ppp0 being up and displayed in ifconfig -a

Additional info:

adsl-setup is not installed, nor is pppoe.conf man page, and IMHO should be included in rp-pppoe rpm.
My connection is already established and works fine on my Windows machine, but I would like a redhat firewall to masquerade and route for my network.  
Please email me!
Comment 1 Ngo Than 2001-10-26 15:45:23 EDT
ok i close this bug, because it works for you.

Note You need to log in before you can comment on or make changes to this bug.