This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55129 - sendmail is losing outgoing mail
sendmail is losing outgoing mail
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: nmh (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 19:04 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 04:32:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-25 19:04:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
I've recently noticed that sendmail loses outgoing mail. The 
/var/log/maillog shows the from= being logged, but not the to=
and the message never appears to be queued. Problem seems to 
occur most often with remote mail, mail to other users in the 
domain seems to work.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.send email
2.
3.
	

Additional info:

Problem showed up after applying the latest set of updates to glibc and
util-linux, so may be related. RPM won't let me backout glibc-2.2.4 for
an older version though, because it's now got glibc-common, so it's hard
to verify that this is the cause.
Comment 1 Florian La Roche 2001-12-08 04:06:07 EST
Is everything working fine after a "service sendmail restart"? There is a
problem with syslog logging after logfile rotation. Could this be the
same problem?

Florian La Roche
Comment 2 Need Real Name 2001-12-12 17:47:50 EST
No, the problem is NOT logging related (I have confirmed this with tcpdump). It
also persists on a clean install of RedHat7.2 + updates.

More investigation shows that the bug only occurs with nmh, and I can workaround
the bug by adding "send: -verbose" to $HOME/.mh_profile. It does not occur in 
Red Hat 6.0 + updates, so I suspect changes in nmh between 6.0 and 7.x.
Comment 3 Oliver Schulze L. 2002-10-05 11:59:49 EDT
So this is a problem with nmh and not sendmail?
Comment 4 Need Real Name 2002-10-05 12:13:03 EDT
It's clear that nmh does something different in the way it submits mail when
verbose logging is enabled. I don't know if the problem is a bug in nmh, or 
a bug in sendmail that is triggered by the difference in submission. My guess
is that nmh is incorrectly configured.
Comment 5 Oliver Schulze L. 2002-10-05 12:18:27 EDT
So, its ok to close this bug?
Does it still happend on RH7.3 or 8.0?
Comment 6 Need Real Name 2002-10-05 12:26:19 EDT
The bug is still present on 7.0 + updates; and closing bug reports because
they haven't been solved in over a year is not acceptable. I haven't tried
7.3 yet.
Comment 7 Oliver Schulze L. 2002-10-05 12:44:38 EDT
I sugest closing it because it is a nmh bug and not a sendmail bug.
I think sendmai is so much mature to have a bug that says: 
"sendmail is loosing mails".
One option is to close this bug and open a new one for nmh.
Comment 8 Need Real Name 2002-10-05 14:42:55 EDT
Has that been confirmed?
Comment 9 Oliver Schulze L. 2002-10-05 14:59:14 EDT
For me yes, because Sendmail never lost any mail in my mailserver.
Maybe you can post a test-case for nmh and sendmail so other can reproduce it.
Again, I don't believe Sendmail has any bugs because it is working for me.
Comment 10 Need Real Name 2002-10-05 15:30:11 EDT
The test case is simple: send mail using nmh, without the verbose option. 
The difficulty is deciding which is incorrectly configured. I don't believe
either has a bug, since other unixes running the same versions don't show
this behaviour. However, I believe one is setup wrongly. I don't believe
we've shown which is it yet.
Comment 11 Oliver Schulze L. 2002-10-05 17:44:31 EDT
can you post your sendmail.mc file and nmh configuration?
Have you tryied using the standard sendmail and nmh config files?
Comment 12 Need Real Name 2002-10-05 18:06:16 EDT
I'm using the default nmh configuration files (the only addition is "send:
-verbose" in $HOME/.mh_profile, which is my workaround for the problem). 

The sendmail.mc is that shipped with RedHat7, plus the addition of:
MASQUERADE_AS(isi.edu)
FEATURE(`masquerade_envelope')
LOCAL_USER(root)

Note You need to log in before you can comment on or make changes to this bug.