Bug 55131 - Upgrading to 7.2 broke my fonts.dir
Upgrading to 7.2 broke my fonts.dir
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 20:02 EDT by Miguel Freitas
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 20:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miguel Freitas 2001-10-25 20:02:18 EDT
Description of problem:
I was using 7.1 with XFree86-4.1.0 from rawhide.
After upgrading to 7.2 (normal upgrade booting from cd)
my X didn't start. I have to run mkfontdir on each diretory
to fix the problem.

How reproducible:
Didn't try

Steps to Reproduce:
1. install 7.1
2. install xfree86 4.1.0 from rawhide (dont know if this is needed)
3. upgrade to 7.2

I will not reproduce it because i can only upgrade my system
to 7.2 once. :)

	

Actual Results:  X didn't start. All fonts.dir were broken/missing and X
could not find "fixed" font.

Expected Results:  Just work

Additional info:

I see this problem as two:
1) upgrading to new xfree packages should not break fonts.dir,
i don't know if mkfontdir is missing from post install scripts
but this should be checked.

2) after trying to initialize X several times i got a very nice
message saying there might be a problem with my card config. 
This is a much appreciated feature but besides runing
Xconfigurator you should also test if the "fixed" font is present
and working. This can be a good idea also for the Xconfigurator
maintainer (i don't plan opening another bug, if you wish forward
this one to him)
Comment 1 Mike A. Harris 2001-10-25 21:26:38 EDT
Due to the fact that during development, packages can and do
end up in varying states of brokenness, Red Hat does not support
upgrades to or from rawhide packages.  This problem is not
reproduceable on a 7.1 stock -> 7.2 upgrade, nor 7.1 + official
updates -> 7.2 upgrade.

There were varying degrees of font breakages and issues during
development, that caused very much the same symptoms that you
have encountered.  In particular, the main nasty that has been
reported the most during beta testing, was a %postun script
gone bad.  The problem was fixed in a later release, however,
the problem exists in the _old_ package's postun script, so if
that broken beta package is installed, then problems will
result upon upgrade.  I'm 98% certain that this is the problem
you have encountered.

Thanks nonetheless for reporting this issue.

Note You need to log in before you can comment on or make changes to this bug.