Bug 55137 - Installer can't load mod for ISA NE2000 card
Installer can't load mod for ISA NE2000 card
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-25 23:22 EDT by daryl herzmann
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-03 14:51:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description daryl herzmann 2001-10-25 23:22:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2 i586)

Description of problem:
Trying to install 7.2 from floppy with drvnet disk, I can not get module
to load to use my ISA SMC EZ Card 1660

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to install
2. Load driver disk
3. Specify NE2000 clone or SMC 
4. Specify io=0x300 and irq=3 
5. Watch 8390 mod load, then not load smc-ultra or ne
6. Scratch my head

Actual Results:  No install

Expected Results:  Install

Additional info:

I am running Roswell 2 on this box, but it was installed by CD.
lsmod reports
ne                      6912   1 
8390                    6112   0  [ne]
modules.conf reports
options ne io=0x300
alias eth0 ne

I tried using the NE clones option in the installer and the smc-ultra
option, but they 
both return the same results :(

Hope this helps.
Comment 1 Michael Fulbright 2001-10-26 15:09:59 EDT
I don't have access to any ISA cards like you describe to reproduce this - did
7.1 work?
Comment 2 daryl herzmann 2001-10-26 20:11:18 EDT
Hi! Thanks for the quick response.  I just tried to install 7.1 and got the same

Is there some way I could get you more info on this card?  The physical card is
rather undescript. I see some info in /etc/isapnp.conf that may be interesting?
(CONFIGURE SMC1660/689397426 (LD 0
 (IO 0 (SIZE 32) (BASE 0x0300) (CHECK))
 (INT 0 (IRQ 3 (MODE +E)))
 (NAME "SMC1660/689397426[0]{SMC EZ Card (1660)  }")
 (ACT Y)

I am probably doing something stupid.  Thanks!
Comment 3 Brent Fox 2001-10-26 20:28:05 EDT
I have an Encore NE2000 ISA card at home that I'll bring to work Monday.
Comment 4 Brent Fox 2001-10-28 18:28:34 EST
Yes, I have duplicated the behavior you are seeing exactly.  I'm looking into
things further...
Comment 5 Brent Fox 2001-10-28 18:58:56 EST
Hmm...things seem to work with a cdrom install, but not with the network floppy
disk.  Is it possible to do a cdrom install?
Comment 6 daryl herzmann 2001-10-28 19:13:28 EST
I was able to do a hard drive install, but I no longer have a CDROM :)  See

I am glad that you were able to replicate the problem.  If you need any more
information, please let me know.   I can round up a CDROM from work and bring it
home Monday night if you wish.

Comment 7 Brent Fox 2001-10-28 19:46:51 EST
Well, I was recommending that you try a cdrom install if you need to get the
machine up and running fast.  That doesn't at all explain why the kernel on the
boot disk won't insert the ne module properly, but at least that would probably
get your system on the network.  
I'll talk to the other guys tomorrow and we'll try to figure out why the ne
module won't insert with the boot kernel.
Comment 8 Brent Fox 2001-11-08 11:37:08 EST
arjan, any idea why the boot kernel won't load the ne module?  I've got a
reproducible test case on my test box.
Comment 9 Arjan van de Ven 2002-01-29 12:33:51 EST
If the cdrom one works it's a big question mark. It's the same module....
Comment 10 Michael Fulbright 2002-02-21 11:56:05 EST
I dont think the cdrom install will try to load the ne2000 module.

Brent do you still have the card?
Comment 11 Brent Fox 2002-02-21 12:16:00 EST
Yeah, I'll bring it to you.

Note You need to log in before you can comment on or make changes to this bug.