This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55142 - kickstart installation failed
kickstart installation failed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 03:27 EDT by Seng Guan Lee
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 03:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt (61.90 KB, text/plain)
2001-10-26 03:29 EDT, Seng Guan Lee
no flags Details
kickstart configuration file (521 bytes, text/plain)
2001-10-28 22:09 EST, Seng Guan Lee
no flags Details

  None (edit)
Description Seng Guan Lee 2001-10-26 03:27:12 EDT
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:Yes


Steps to Reproduce:
1. nfs kickstart install
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Seng Guan Lee 2001-10-26 03:29:34 EDT
Created attachment 35164 [details]
anacdump.txt
Comment 2 Brent Fox 2001-10-26 12:13:27 EDT
Can you attach the kickstart file that you used?
Comment 3 Seng Guan Lee 2001-10-28 22:09:33 EST
Created attachment 35342 [details]
kickstart configuration file
Comment 4 Brent Fox 2001-10-29 08:29:15 EST
I see one problem with the kickstart file.  The "device" line, which reads:
device ethernet eepro100
should be:
device eth eepro100

Have a look at:
http://www.redhat.com/docs/manuals/linux/RHL-7.2-Manual/custom-guide/s1-kickstart2-options.html
for all the valid kickstart options.

Does this solve the problem?

Comment 5 Seng Guan Lee 2001-10-29 21:15:08 EST
Hi there,

>Does this solve the problem?
No, I have been using this for rh6.2 & 7.1 and they are ok.  Tried with "eth"
but the same problem exist.

BTW, I have another option which work for me in rh7.1 but not in rh7.2

"part / --size 2048 --onprimary 1" work in rh7.1 but "--onprimary" is not
accepted by rh7.2 any more.  I have to change it to something like

part /boot --size 50 --asprimary

Thanks
Guan Lee
Comment 6 Brent Fox 2001-10-30 15:20:45 EST
Ok, I did a kickstart install with your kickstart file just fine.  The only
modifications I had to make were the nfs line (I had to point it to our NFS
server) and I had to change the sizes for the partitions to be smaller so it
would fit on my disk.  I don't know why you are seeing the traceback that you
saw.  I can't reproduce it.

Here's the file I used:

lang en_US
network --bootproto dhcp
nfs --server porkchop.test.redhat.com --dir /mnt/test/enigma-i386/i386/
keyboard us
mouse --emulthree genericps/2 --device ttyS1
rootpw --iscrypted $1$eY7B2IxS$wZ73ckUg7OtR6NWKBIko30
auth --useshadow --enablemd5
install 
device ethernet eepro100
timezone --utc GMT
skipx

bootloader --useLilo
zerombr yes
clearpart --all

part /boot --size 50 --asprimary
part / --size 1024 --asprimary
part /usr --size 1024 --asprimary
part swap --size 1024
part /var --size 1024 --grow

%packages
@ Base
Comment 7 Seng Guan Lee 2001-10-31 03:19:08 EST
Hi there,

I found the problem.   I missed a new required option which was introduce in
rh7.2 

langsupport --default en_US en_US

The kickstart installation go well now.  Thanks!  Please close the case

Guan Lee
Comment 8 Brent Fox 2001-10-31 08:32:36 EST
Ok.  I'm glad things are working now.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.