Bug 551441 - Video freezes in Theora video mode
Summary: Video freezes in Theora video mode
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ekiga
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-30 18:05 UTC by Wolfram Wagner
Modified: 2010-12-04 01:03 UTC (History)
3 users (show)

Fixed In Version: ekiga-3.2.7-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-04 01:03:37 UTC
Type: ---


Attachments (Terms of Use)
The log of the time when I told you about the problem (459.27 KB, text/plain)
2010-02-09 16:21 UTC, Wolfram Wagner
no flags Details

Description Wolfram Wagner 2009-12-30 18:05:37 UTC
Description of problem:
Ekiga crashes with a frozen video transmission within a few seconds. The picture is transmitted if the session lasts long enough.
I can exclude the setup, firewall and network issues, as if I use the default setting h261 it works fine. Echo test works too, because it uses to h261.

How reproducible:
1. Change sequence of video codecs to have theora at the top or disable h261 completely. 
2. Call someone, who is willing to receive theora. (who has it enabled)
  
Actual results:
Video freezes

Expected results:
Ongoing session

Comment 1 Wolfram Wagner 2010-01-01 21:45:49 UTC
logging:
RateController  Report:Total frames:in=816,out=406,dropped=410(50%)
Media Patch:0x3ee5f710 RateController  Report:in=19 fps,out=9 fps,target=30 fps           
Media Patch:0x3ee5f710 RateController  Report:current=58550 bps,target=200000 bps         
Media Patch:0x2bed7710 RTP     Session 1, transmit statistics:  packets=2101 octets=109252 avgTime=20 maxTime=34 minTime=6
Media Patch:0x3ee5f710 Patch   Media conversion (primary) failed                                                          
Media Patch:0x3ee5f710 Patch   WriteFrame failed     

What I see is that 50% of the frames are dropped before media conversation finally fails.

Comment 2 Peter Robinson 2010-02-03 02:27:39 UTC
Could you please try to recreate this crash by running ekiga with command
line options of 'ekiga -d 4' to get debug output and please attach it too this
bug as a text file.

Comment 3 Wolfram Wagner 2010-02-07 19:28:51 UTC
Hi again,

I am sorry for the delay, it took a while until I had time to perform the test.

The output above was from the d 4 output...

Unfortunately, or better fortunately the problem is not reproducible by today. I configured the connection as before and called: I worked fine, all the time.

As I haven't changed anything (ok, I installed all updates) I assume that if this is not a temporary exception to the rule, a patch has brought a relive in this matter.

I will continue using the theora mode and if you don't hear from me again, the problem is gone at least here.

Thank to the unknown, who made it disappear!

Wolfram

Comment 4 Wolfram Wagner 2010-02-09 16:20:21 UTC
I had the same issue today again. 

I set theora to my favorite codec and set screen resolution to max.

I tried to log it with d 4 output, but all I got was three lines, as if -d 4 was not active.

Unfortunately my contact to test is not available right now, so I cannot retry.

I am attaching the -d 4 output of last time.

Wolfram

Comment 5 Wolfram Wagner 2010-02-09 16:21:18 UTC
Created attachment 389796 [details]
The log of the time when I told you about the problem

Comment 6 Fedora Update System 2010-05-31 17:47:55 UTC
ekiga-3.2.7-1.fc12,opal-3.6.8-1.fc12,ptlib-2.6.7-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ekiga-3.2.7-1.fc12,opal-3.6.8-1.fc12,ptlib-2.6.7-1.fc12

Comment 7 Fedora Update System 2010-06-01 18:17:26 UTC
ekiga-3.2.7-1.fc12, opal-3.6.8-1.fc12, ptlib-2.6.7-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ekiga opal ptlib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ekiga-3.2.7-1.fc12,opal-3.6.8-1.fc12,ptlib-2.6.7-1.fc12

Comment 8 Fedora Update System 2010-06-07 22:13:35 UTC
ekiga-3.2.7-1.fc12, opal-3.6.8-1.fc12, ptlib-2.6.7-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Wolfram Wagner 2010-06-20 12:39:26 UTC
Today I had the chance to test: As long as theora video codec is disabled everything works. If I enable Theora codec my oposite sees me for a few moments before it freezes.
My conference partner runs Fedora 11 with ekiga 3.2.7, updated by today. I have almost 17.000 kb/s bandwith on the other side only 1000 kb/s. The fact that it runs without Theora, should show, that the routing settings are alright.

So this issue is still open. Unfortunally. Am I the only one who has this problem. Maybe I should try with someone who does not have this problem. Or how can I help to solve this issue?

Comment 10 Bug Zapper 2010-11-04 02:12:51 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Bug Zapper 2010-12-04 01:03:37 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.