Bug 55146 - xterm -e breaks terminfo?
Summary: xterm -e breaks terminfo?
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-26 10:53 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 21:41:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-26 10:53:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011015

Description of problem:
xterm -e vim -- vim thinks erase is ^h instead ^? Why? If I run xterm and
than vim, all is ok. (I have vim6.0 from rawhide, xterm is from normal 7.2)

Version-Release number of selected component (if applicable):
vim-enhanced-6.0-2

How reproducible:
Always

Steps to Reproduce:
1. xterm -e vim
2. try to something write
3. try to erase it with basck space
	

Additional info:

Comment 1 Preston Brown 2001-11-06 17:19:34 UTC
seems to be a vim issue


Comment 2 Preston Brown 2001-11-06 17:21:06 UTC
no, seems to be an X issue.  konsole and gnome-terminal do not behave this way.

I would possibly consider this issue possibly unsupported, as both konsole and 
gnome-terminal are the supported terminal emulators.


Comment 3 Mike A. Harris 2001-11-06 21:41:04 UTC
Feedback from upstream:

This is not a bug; it is OS dependent behavior. Stick something like this
in your .Xresources:
 
    xterm*ttyModes: erase ^?

Comment 4 Mike A. Harris 2001-11-07 18:56:00 UTC
Further debugging points towards a bug in xterm.  Upstream XFree86
maintainers have been informed of this problem so that someone
with expertise with xterm internals can hopefully find a solution.



Note You need to log in before you can comment on or make changes to this bug.