Bug 551494 - RFE: Support Mobile development (package eclipse sequoyah)
RFE: Support Mobile development (package eclipse sequoyah)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-30 18:51 EST by Jeff Garzik
Modified: 2013-07-02 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-18 11:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Garzik 2009-12-30 18:51:27 EST
Description of problem:

Fedora offers a poor environment for creating J2ME mobile phone applications.  Very little developer support at all.  However, eclipse already has a widely used, industry supported sub-project for this:  MTJ.

Request that someone package and ship the stable, supported Mobile Tools for Java (MTJ) that is available at

          http://www.eclipse.org/dsdp/mtj/
Comment 1 Andrew Overholt 2010-01-04 09:06:27 EST
Packaging Eclipse plugins is quite easy.  The guidelines are here:

http://fedoraproject.org/wiki/Packaging:EclipsePlugins

If you want help, email me.
Comment 2 Jeff Garzik 2010-01-11 09:13:20 EST
I would be happy to package it...   but given the kernel and Project Hail, I really don't have time to maintain it.

Is there someone in the Eclipse community who could be package maintainer?

This bug was filed because I think packaging MTJ would be a very easy way to enable Fedora (and RHEL for Red Hat, my employer) development of mobile phone software, for millions of existing and future mobile phones -- a very big market.

Regards,

       Jeff
Comment 3 Andrew Overholt 2010-01-11 09:19:58 EST
I don't personally know anyone in the Eclipse community who could be the maintainer.  My experience with MTJ and their community is zero.  Perhaps email their development list?

Re-reading my comment I can see how it seemed cold.  Sorry, that wasn't what I intended.  I'm happy to help whomever would like to package this; I just don't have time to do it myself.
Comment 4 Fedora Admin XMLRPC Client 2010-08-31 11:58:53 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Krzysztof Daniel 2012-04-30 05:19:12 EDT
MTJ looks abandoned. All mobile components are now in Sequoyah.

http://www.eclipse.org/sequoyah/

Changing bug title as we need some mobile tools in Fedora.
Comment 6 Alexander Kurtakov 2013-03-18 11:24:08 EDT
Closing the bug because: 
* noone willing to do anywork on it
* Eclipse component is the wrong one as this is Eclipse platform and plugins are separate packages/components
* there is http://fedoraproject.org/wiki/Package_maintainers_wishlist for wishlist so it can be added there is one cares

Note You need to log in before you can comment on or make changes to this bug.