Bug 551504 - SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c1449392f9b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-31 00:49 UTC by alfonsomoras@gmail.com
Modified: 2010-01-30 14:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-31 14:00:43 UTC


Attachments (Terms of Use)

Description alfonsomoras@gmail.com 2009-12-31 00:49:04 UTC
Resúmen:

SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /root.

Descripción Detallada:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Permitiendo Acceso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Información Adicional:

Contexto Fuente               system_u:system_r:xdm_t:s0-s0:c0.c1023
Contexto Destino              system_u:object_r:admin_home_t:s0
Objetos Destino               /root [ dir ]
Fuente                        gdm-session-wor
Dirección de Fuente          /usr/libexec/gdm-session-worker
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          gdm-2.28.1-25.fc12
Paquetes RPM Destinos         filesystem-2.4.30-2.fc12
RPM de Políticas             selinux-policy-3.6.32-56.fc12
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (removed)
Plataforma                    Linux (removed) 2.6.31.6-166.fc12.x86_64 #1 SMP Wed
                              Dec 9 10:46:22 EST 2009 x86_64 x86_64
Cantidad de Alertas           4
Visto por Primera Vez         dom 13 dic 2009 07:28:12 CST
Visto por Última Vez         mié 30 dic 2009 18:28:19 CST
ID Local                      daec2642-20cd-4742-aa47-47ef17b51c3e
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1262219299.609:54): avc:  denied  { write } for  pid=7474 comm="gdm-session-wor" name="root" dev=dm-0 ino=81921 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1262219299.609:54): arch=c000003e syscall=2 success=no exit=-13 a0=105e3f0 a1=c2 a2=180 a3=20 items=0 ppid=7446 pid=7474 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-56.fc12,catchall,gdm-session-wor,xdm_t,admin_home_t,dir,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:dir write;

Comment 1 Daniel Walsh 2009-12-31 14:00:43 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.