Bug 551546 - [abrt] crash detected in gnome-packagekit-2.28.3-0.1.20091211git.fc12
Summary: [abrt] crash detected in gnome-packagekit-2.28.3-0.1.20091211git.fc12
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6c23d4a580940aba1679c5130f2...
: 538658 538786 544468 547801 550504 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-31 08:00 UTC by Michael
Modified: 2010-03-23 10:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-23 10:49:11 UTC


Attachments (Terms of Use)
File: backtrace (14.91 KB, text/plain)
2009-12-31 08:00 UTC, Michael
no flags Details

Description Michael 2009-12-31 08:00:51 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/bin/gpk-repo --parent-window 104857603
component: gnome-packagekit
executable: /usr/bin/gpk-repo
kernel: 2.6.31.9-174.fc12.x86_64
package: gnome-packagekit-2.28.3-0.1.20091211git.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Michael 2009-12-31 08:00:59 UTC
Created attachment 381061 [details]
File: backtrace

Comment 2 Matthias Clasen 2010-01-04 22:57:32 UTC
Looking at the code of pk_client_repo_enable, it forgets to copy local_error over to error in at least one error path:


       ret = pk_client_allocate_transaction_id (client, &error_local);
        if (!ret)
                goto out;

Comment 3 Matthias Clasen 2010-01-04 22:58:19 UTC
I'll also notice that gpk_misc_enabled_toggled leaks path if the capability is missing.

Comment 4 Matthias Clasen 2010-01-04 23:08:30 UTC
*** Bug 550504 has been marked as a duplicate of this bug. ***

Comment 5 Matthias Clasen 2010-01-04 23:08:52 UTC
*** Bug 547801 has been marked as a duplicate of this bug. ***

Comment 6 Matthias Clasen 2010-01-04 23:09:14 UTC
*** Bug 544468 has been marked as a duplicate of this bug. ***

Comment 7 Matthias Clasen 2010-01-04 23:09:37 UTC
*** Bug 538658 has been marked as a duplicate of this bug. ***

Comment 8 Matthias Clasen 2010-01-04 23:09:56 UTC
*** Bug 538786 has been marked as a duplicate of this bug. ***

Comment 9 Richard Hughes 2010-01-05 09:08:21 UTC
(In reply to comment #3)
> I'll also notice that gpk_misc_enabled_toggled leaks path if the capability is
> missing.  

Only in gnome-2-28, the leak is already plugged in master:

commit 60fbb5aa0e9b84f201439080adb0205a88a1eeeb
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Jan 5 08:48:38 2010 +0000

    trivial: don't leak path or client in the error path

Comment 10 Richard Hughes 2010-01-05 09:25:18 UTC
(In reply to comment #2)
>        ret = pk_client_allocate_transaction_id (client, &error_local);
>         if (!ret)
>                 goto out;  

commit 47619f1706f164266ca635cf68e7c4215e71236c
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Jan 5 09:16:53 2010 +0000

    bugfix: Ensure to set the correct error if getting the transaction ID fails. Fixes rh#551546

I'll push out a new upstream release later today.

Comment 11 Fedora Update System 2010-01-05 11:03:45 UTC
PackageKit-0.5.6-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/PackageKit-0.5.6-1.fc12

Comment 12 Fedora Update System 2010-01-05 22:54:52 UTC
PackageKit-0.5.6-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0193

Comment 13 Fedora Update System 2010-01-12 23:52:42 UTC
PackageKit-0.5.6-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.