Bug 551653 - SELinux is preventing /usr/bin/kdm "read" access on .dmrc.
Summary: SELinux is preventing /usr/bin/kdm "read" access on .dmrc.
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b9c2847c810...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-01 02:10 UTC by adrian1h
Modified: 2010-01-04 10:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-04 10:59:33 UTC


Attachments (Terms of Use)

Description adrian1h 2010-01-01 02:10:22 UTC
Summary:

SELinux is preventing /usr/bin/kdm "read" access on .dmrc.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .dmrc [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.3-7.fc12.1
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-59.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.9-174.fc12.i686.PAE #1
                              SMP Mon Dec 21 06:04:56 UTC 2009 i686 athlon
Alert Count                   2
First Seen                    Thu 31 Dec 2009 09:08:13 PM EST
Last Seen                     Thu 31 Dec 2009 09:08:13 PM EST
Local ID                      e1cc3389-dbe9-4c2a-92d1-b80fd804cb1e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1262311693.60:22087): avc:  denied  { read } for  pid=17902 comm="kdm" name=".dmrc" dev=dm-1 ino=31792 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1262311693.60:22087): avc:  denied  { open } for  pid=17902 comm="kdm" name=".dmrc" dev=dm-1 ino=31792 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1262311693.60:22087): arch=40000003 syscall=5 success=yes exit=3 a0=928bda0 a1=8800 a2=0 a3=0 items=0 ppid=17886 pid=17902 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-59.fc12,catchall,kdm,xdm_t,admin_home_t,file,read
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file { read open };

Comment 1 Miroslav Grepl 2010-01-04 10:59:33 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.