Bug 551665 - [abrt] crash detected in openconnect-2.12-1.fc12
Summary: [abrt] crash detected in openconnect-2.12-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openconnect
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f1c15d20b840c25f5900cc29a71...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-01 04:19 UTC by Dan Johansson
Modified: 2010-01-05 22:55 UTC (History)
2 users (show)

Fixed In Version: 2.20-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-05 22:55:31 UTC
Type: ---


Attachments (Terms of Use)

Description Dan Johansson 2010-01-01 04:19:06 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/libexec/nm-openconnect-auth-dialog -u 40ae28c9-dec7-4831-a454-1826e3195de4 -n VPN connection 1 -s org.freedesktop.NetworkManager.openconnect
component: openconnect
executable: /usr/libexec/nm-openconnect-auth-dialog
kernel: 2.6.31.9-174.fc12.x86_64
package: openconnect-2.12-1.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Dan Johansson 2010-01-01 04:19:09 UTC
Created attachment 381145 [details]
File: backtrace

Comment 2 David Woodhouse 2010-01-01 10:54:02 UTC
Hm, deep within libxml's xmlFreeDoc() function. It looks like memory corruption of some kind within libxml's data structures, which may not be libxml's fault.

I've looked over our use of libxml and used valgrind, and I can't see any problems except for some memory leaks because I didn't realise certain return values needed to be freed. I've fixed that in git (http://git.infradead.org/users/dwmw2/openconnect.git/commitdiff/08731af8) but it's not likely to fix your problem.

I'm assuming this happened after you entered your username and password into the dialog and hit 'login'? 

Can you reproduce it?

You don't need to disconnect and reconnect to the VPN -- you can just run the command line above (nm-openconnect-auth-dialog -u ...) and it will just do the authentication stage.

If you run 'openconnect --cookieonly $VPNSERVER' that should also use the same authentication and XML parsing code. Can you reproduce it that way?

Comment 3 Dan Johansson 2010-01-02 02:51:18 UTC
Your right it does crash on login. But not always, usually once in every 10 tries. I am trying to figure out the exact sequence that causes it, and I will try some of your suggestions.

Dan

Comment 4 David Woodhouse 2010-01-02 10:25:22 UTC
Does this only happen if the login form has been shown more than once -- if you've mistyped your password or changed the host?

Comment 5 David Woodhouse 2010-01-02 11:05:36 UTC
I think the answer to my question above is 'yes', and I think it's fixed by http://git.infradead.org/users/dwmw2/openconnect.git/commitdiff/5b828b68

Are you able to build from the git tree and test that, or do I need to put together a package?

Comment 6 David Woodhouse 2010-01-03 18:59:41 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1899841

If you confirm that this works, I'll make a new release and push it as an update.

Comment 7 Dan Johansson 2010-01-04 04:42:37 UTC
RPM Package would be easiest, but ill give build it a shot.

Comment 8 Dan Johansson 2010-01-04 05:16:38 UTC
Assuming I built it right, it does seem to fix the problem. I can't entirely be sure though, as I couldn't find a reliable way to reproduce the problem.

Comment 9 Fedora Update System 2010-01-04 16:23:03 UTC
openconnect-2.20-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openconnect-2.20-1.fc12

Comment 10 Fedora Update System 2010-01-05 22:55:27 UTC
openconnect-2.20-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.