Bug 55170 - /boot/kernel.h doesn't say "athlon" on athlon
/boot/kernel.h doesn't say "athlon" on athlon
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 11:47 EDT by Kirk
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 15:08:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kirk 2001-10-26 11:47:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
When compiling the alsa drivers, the following errors occur when the
modules are trying to load:
tarting sound driver: snd-card-via686a /lib/modules/2.4.9-7/misc/snd.o:
> unresolved symbol register_sound_special_R8b1df5ec
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol
> register_sound_dsp_Rb10c83d0
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol
> remove_proc_entry_Ra3bc3312
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol mem_map_Rb8347d40
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol proc_root_Rdfcdd0e8
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol
> register_chrdev_R72eee44e
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol
> vfs_follow_link_R3d1cab55
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol __pollwait_R2d775706
> /lib/modules/2.4.9-7/misc/snd.o: unresolved symbol
> create_proc_entry_R25ee68d2
> /lib/modules/2.4.9-7/misc/snd.o: insmod /lib/modules/2.4.9-7/misc/snd.o
> failed
> /lib/modules/2.4.9-7/misc/snd.o: insmod snd-card-via686a failed

While I realize alsa isn't supported by redhat, and its not part of your
distribution, it simply works better than the oss drivers.  To correct this
error, I installed the i686 kernel and everything worked fine.

Version-Release number of selected component (if applicable):
2.4.9-7-athlon


How reproducible:
Always

Steps to Reproduce:
1.Install the athlon kernel (2.4.9-7)
2.Attempt to compile/install alsa drivers
3.
	

Actual Results:  modules would not install due to unresolved symbols, see
error above

Expected Results:  the modules should have loaded

Additional info:

Redhat 7.2 with all updates...I didn't try on the default kernel because
the update was released immediately.
Comment 1 Arjan van de Ven 2001-10-26 12:36:58 EDT
wild hunch: can you check /boot/kernel.h
and see if it says "athlon" and not i686 ?
if it says i686, can you change that and then rebuild also ?
Comment 2 Kirk 2001-10-26 13:25:12 EDT
Okay, but I ditched the atlon kernel and am running the i686 kernel instead...do
you want this done when running the athlon kernel (I think so, but just
checking).  If so, what is the best way to get it back?  I don't think that I
can have both athlon and i686 of the same kernel loaded in the rpm database, so
should I boot to 2.4.7 and remove the 2.4.9 i686 kernel and install the 2.4.9
athlon kernel?  I think that is how I did it last time.
Comment 3 Arjan van de Ven 2001-10-26 13:27:40 EDT
if i686 kernel works the problem I described almost certainly was the cause.
No need to switch from a working kernel; the athlon kernel is somewhat faster
under certain uses (compared to the i686); other than that there is no
difference.
Comment 4 Kirk 2001-11-03 01:22:49 EST
I just upgraded to 2.4.9-13 and the same thing happened when reinstalling the
NVIDIA drivers (unresolved symbols).  I made the changes in boot.h and the
driver worked properly.
Comment 5 Kirk 2001-11-03 01:33:52 EST
However, when compiling the alsa drivers, I still got one error when trying to
install them:
Starting sound driver: snd-card-via686a
/lib/modules/2.4.9-13/misc/snd-rawmidi.o: unresolved symbol
snd_seq_device_new_R4317f987
/lib/modules/2.4.9-13/misc/snd-rawmidi.o: insmod
/lib/modules/2.4.9-13/misc/snd-rawmidi.o failed
/lib/modules/2.4.9-13/misc/snd-rawmidi.o: insmod snd-card-via686a failed
done


Will try the i686 version of this kernel.
Comment 6 Kirk 2001-11-03 01:59:59 EST
Using the i686 kernel, everything worked.  I realize that the kernels probably
aren't that much difference, I would like to get the full use of my Athlon, and
I don't understand what's happening to make these different.
Comment 7 Bill Crawford 2001-11-06 08:51:14 EST
I had some issues getting ALSA to work but I mostly got it to work by making
/usr/src/linux point to a current build tree, and adding lots of entries to
/etc/modules.conf.  Running "depmod -ea" should show whether the symbols are
really unresolvable or whether you just need to install another module first.
Comment 8 Albert Cheung 2001-11-14 00:12:26 EST
AMD760 chipset motherboards seem to be compatible with RedHat 7.2 Athlon 
optimized kernel. It is just VIA chipset which causes all the problems..

I personally use Abit KG7-Lite with the latest BIOS, RedHat 7.2 seems to be 
running fine here.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.