Bug 5518 - NCFTP does not work
NCFTP does not work
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 18:20 EDT by Yil-Kyu Kang
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-04 18:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yil-Kyu Kang 1999-10-04 18:20:57 EDT
When selecting NCFTP from "gnome panel" -> internet -> nfctp
it does not work. Nothing happens.
Comment 1 Bill Nottingham 1999-10-04 18:27:59 EDT
fixed in ncftp-3.0.beta21-1, in the next Raw Hide release.
Comment 2 Jan Carlson 2000-02-06 16:37:59 EST
The fix did not appear in Rawhide ncftp-3.0beta21-1.i386.rpm or
ncftp-3.0beta21-2.i386.rpm.  Both still have Terminal=1 in
ncftp.desktop. Because Gnome interprets 1 as false, no window appears,
and ncftp complains into ~/.xsession-errors.

OFFENDING FILE: = /etc/X11/applnk/Internet/ncftp.desktop

POSSIBLE SOLUTION: replace Terminal=1 with Terminal=true

TO VERIFY THIS BUG, DO rpm -Uvh --allfiles ncftp*.rpm.
Then try to run ncftp from the Gnome|Internet menu.
Otherwise rpm will not replace your current ncftp.desktop.
It's a config file.

This is the only remaining .desktop file that contains Terminal=1,
after applying all RH6.1 updates and Gotchas fixes.  Lots of them
contain Terminal=0.  Gnome might need to understand 1 as an alternate
for true, but it doesn't in RH6.1 with all updates and gotchas fixes.
Comment 3 Bill Nottingham 2000-02-07 10:42:59 EST
I believe the current fixes are in the GNOME and KDE
libraries, in that they now both understand the
same syntax.
Comment 4 Jan Carlson 2000-02-07 20:10:59 EST
All my rpms here are upgraded to the current Rawhide, but the "Terminal=1"
in ncftp is still interpreted as Terminal=false and ncftp won't come up.
Maybe in the next Rawhide?

Note You need to log in before you can comment on or make changes to this bug.