Bug 551801 - [abrt] crash detected in audacious-2.1-7.fc12 : stack smashing detected in ui_svis_expose at ui_svis.c:443
Summary: [abrt] crash detected in audacious-2.1-7.fc12 : stack smashing detected in ui...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious-plugins
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL: http://jira.atheme.org/browse/AUDPLUG...
Whiteboard: abrt_hash:cc43bd00f47324fd7883adb86ad...
: 551800 552346 554779 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-02 05:44 UTC by David Timms
Modified: 2010-02-02 01:10 UTC (History)
4 users (show)

Fixed In Version: 0.4-1.fc12.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-02 01:10:09 UTC


Attachments (Terms of Use)
File: backtrace (32.41 KB, text/plain)
2010-01-02 05:45 UTC, David Timms
no flags Details
$HOME/.config/audacious/config as req. (4.59 KB, text/plain)
2010-01-02 23:32 UTC, David Timms
no flags Details

Description David Timms 2010-01-02 05:44:59 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. playing a single wav audio file
2. press the up arrow (shade)

Comment
-----
This report is with built in wav playback capability, hence trying to determine if mp3 playback was the trigger, from last report bz: 551800, hopefully same bt.
Note that with either a list of mp3 or a single wav, if a track isn't playing when up (shade) is clicked, the app is reduced to a single line of buttons, OK.

Attached file: backtrace
cmdline: audacious2
component: audacious
executable: /usr/bin/audacious2
kernel: 2.6.31.9-174.fc12.x86_64
package: audacious-2.1-7.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 David Timms 2010-01-02 05:45:02 UTC
Created attachment 381249 [details]
File: backtrace

Comment 2 Michael Schwendt 2010-01-02 11:48:00 UTC
* Which skin and gtk settings do you use?
  Can you attach your $HOME/.config/audacious/config file?

* Can you reproduce this with Audacious 2.2 from updates-testing?
  Note that you may need to wait for the 3rd party mp3 plugins to be published.

Comment 3 Michael Schwendt 2010-01-02 11:48:39 UTC
*** Bug 551800 has been marked as a duplicate of this bug. ***

Comment 4 Michael Schwendt 2010-01-02 14:05:09 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=1898663

[The fix will eventually be merged into the 2.2 test-update. Doing it right now would pull back the test updates into "pending".]

Comment 5 David Timms 2010-01-02 23:32:08 UTC
Created attachment 381333 [details]
$HOME/.config/audacious/config as req.

(In reply to comment #2)
> * Which skin and gtk settings do you use?
In audacious preferences|skinned interface=default=unarchived winamp 2.x skin.
The item Disable inline gtk theme is not checked.

>   Can you attach your $HOME/.config/audacious/config file?
Attached.

> * Can you reproduce this with Audacious 2.2 from updates-testing?
audacious.x86_64         2.2-4.fc12 @updates-testing
audacious-libs.x86_64    2.2-4.fc12 @updates-testing
audacious-plugins.x86_64 2.2-7.fc12 @updates-testing
There is an extra menu item: Audacious (GTKui). This can be max/min-mized ok.
The same issue occurred with the skinned interface.

>   Note that you may need to wait for the 3rd party mp3 plugins to be
> published.
I removed them for the test.

(In reply to comment #4)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1898663
> 
> [The fix will eventually be merged into the 2.2 test-update. Doing it
> right now would pull back the test updates into "pending".]
audacious.x86_64             2.2-4.fc12    @updates-testing                     
audacious-libs.x86_64        2.2-4.fc12    @updates-testing                     
audacious-plugins.x86_64     2.2-8.fc12    @/audacious-plugins-2.2-8.fc12.x86_64
The update to -plugins resolves this for me. The visualization (originally spectrum, narrow bands), now shows below the audacious, can be toggled between each of the waveform, peak and none items. The other (shade)d functions also work as expected.

Comment 6 Fedora Update System 2010-01-05 22:53:55 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-8.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 7 Michael Schwendt 2010-01-12 16:24:07 UTC
*** Bug 554779 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-01-12 23:30:26 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 9 Fedora Update System 2010-01-12 23:31:24 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 10 Fedora Update System 2010-01-12 23:32:16 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 11 Fedora Update System 2010-01-26 00:57:37 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-7.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 12 Michael Schwendt 2010-01-27 10:42:15 UTC
Third-party add-on packages for Audacious 2.2 are available
in their respective -updates-testing repository.

Please give feedback on the Audacious 2.2 test update:
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

There are no plans to continue with Audacious 2.1.

Comment 13 Michael Schwendt 2010-01-28 21:25:09 UTC
*** Bug 552346 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2010-02-01 01:23:43 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 15 Fedora Update System 2010-02-02 01:09:05 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.