Bug 55182 - Web page view fails with Mozilla >0.9.2
Web page view fails with Mozilla >0.9.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 14:32 EDT by E Mair
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 14:47:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Mair 2001-10-26 14:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
After upgrading Mozilla to 0.9.5, the web page view in Nautilus 1.0.4
doesn't work. I always get the message "Web page view encountered an error
while starting up".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to the latest Mozilla (currently 0.9.5) by RPM from mozilla.org
2. Open a Nautilus window. Click on a help document in the side-bar, try to
view a HTML document or enter an HTTP URL.
3. Downgrade to Mozilla 0.9.2 (the horror, the horror!) and everything will
work again. Well, except having the functionality and speed improvements of
Mozilla 0.9.5 of course...


Actual Results:  You'll get a "Web page view encountered an error while
starting up" message (which also is misspelt in the Swedish locale).

Expected Results:  Nautilus should render and display the HTML, man etc.
document.

Additional info:

The Nautilus RPM's dependencies specify mozilla >=0.9.2 IIRC, so according
to that a Mozilla upgrade should work fine.

I set the severity to "High" since this prevents upgrading such an
important package as Mozilla or it renders a key feature of Nautilus
useless, and I understand Nautilus 1.0.5 has been out for quite a while now
without showing up as an up2date upgrade.

P.S. to the translator(s): "Web page view" is incorrectly translated to the
linguistic abomination "Webbsida-vyn" in the Swedish Nautilus locale. It
should be "Webbsidevyn", or if you like me intensely hate the ugly
swedification "webb" of English slang it should be "WWW-sidevyn". I
personally prefer "WWW-visningen" or "HTML-visningen".
("Nu skall jag tjatta pe webben och ldsa e-mejl, hejde!") >:^~
Comment 1 Havoc Pennington 2001-10-26 15:52:10 EDT
We don't support RPMs that we haven't released. The Nautilus we shipped isn't
intended to work with the new Mozilla.

If you want as-yet-unreleased desktop RPMs, see
ftp://people.redhat.com/hp/gnomehide, but read the README there first for
important caveats. Those RPMs do not count as released and aren't supported,
they are just development snapshots.
Comment 2 E Mair 2001-10-26 21:36:43 EDT
Thanks! I got both Nautilus 1.0.5 and Mozilla 0.9.5 working fine. I noticed that
Nautilus 1.0.5 needed libgnomevfs-pthread.so, and found this in the
gnome-vfs-devel RPM. This was not shown by that Nautilus RPM's dependencies.


OTOH, I really think RH's Nautilus packages should work with Mozilla.org's own
original Mozilla packages. I mean we're not talking about "Joe Schmoe's 31337
RPM Emporium" on a Geocities page here, but the official source of the software
in question.
Comment 3 David Kaplan 2001-12-02 15:51:04 EST
I have the same problem and the same basic opinion about nautilus working with
newer releases of mozilla.  Mozilla is so integral to redhat that users have to
be able to upgrade it without worry.
Comment 4 Havoc Pennington 2001-12-02 16:31:46 EST
Guys, we can't guarantee that our software will work with software that has not
yet been released, but will be released, by someone else who is not thinking
"keep Red Hat working" as their primary goal. ;-)
mozilla.org changed the interface to mozilla; that is not something we can keep
them from doing, and they haven't promised to avoid it. So we rely on 
having specific mozilla versions so that the interface is stable. There is no
other way to use Mozilla.

If you replace a Red Hat system component with third-party packages, you're on
your own. That said, again blizzard from mozilla.org does build the packages in
gnomehide, and those are kept in sync with the devel Nautilus packages in there.
They are typically up to date or close to it.

Note You need to log in before you can comment on or make changes to this bug.