Bug 55183 - dos2unix mangles file permissions
Summary: dos2unix mangles file permissions
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dos2unix (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-26 18:46 UTC by Bob Farmer
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 00:35:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:195 low SHIPPED_LIVE dos2unix and unix2dos bug fix update 2005-05-19 04:00:00 UTC

Description Bob Farmer 2001-10-26 18:46:41 UTC
Description of problem:
dos2unix, when running in "old file mode", always changes the permissions
on the file it runs on to 600. 

How reproducible:
Always

Steps to Reproduce:
1. echo test >a.txt
2. chmod 666 a.txt
3. dos2unix a.txt
4. ls -al a.txt	

Actual Results:  a.txt now has permissions 600

Expected Results:  a.txt's permissions should remain the same.  I can think
of no legitimate reason why dos2unix should modify them.  The behavior
isn't documented either.

Comment 1 Mike A. Harris 2003-05-21 15:29:47 UTC

*** This bug has been marked as a duplicate of 91331 ***

Comment 2 Tim Powers 2005-05-20 00:35:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-195.html



Note You need to log in before you can comment on or make changes to this bug.