Bug 551906 - Request to update ddclient to version 3.8.0
Summary: Request to update ddclient to version 3.8.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ddclient
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 579336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-03 01:35 UTC by Stephen Beahm
Modified: 2010-06-22 01:12 UTC (History)
6 users (show)

Fixed In Version: ddclient-3.8.0-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-29 11:09:03 UTC


Attachments (Terms of Use)

Description Stephen Beahm 2010-01-03 01:35:43 UTC
Please update ddclient to version 3.8.0.

Version 3.8.0 supports noip protocol.

Comment 1 J. Randall Owens 2010-01-11 00:28:10 UTC
I've got scratch packages built on Koji:
F11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1912934
F12: https://koji.fedoraproject.org/koji/taskinfo?taskID=1912928

Also, a variant with my patch to allow it to update Hurricane Electric IPv6 tunnels as well:
F11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1912966
F12: https://koji.fedoraproject.org/koji/taskinfo?taskID=1912964

(I've submitted the patch upstream, but wimpunk hasn't taken any action on it yet, so if you prefer not to include it, I certainly won't be miffed.)

So, if someone who can commit (I think this means Robert) could get those into the pipeline, this should be pretty straightforward.

P.S. Robert, while you're poking at things anyway, could I get approved for the F12 & rawhide watches?  Right now, I'm only watching F11.

Comment 2 J. Randall Owens 2010-01-11 01:05:45 UTC
Oh, the 3.8.0-1 source packages include an old form of the HE tunnel patch, but do not apply it; I had to remake it to apply to the 3.8.0 instead of the SVN checkout I developed it on.  If you choose to leave it out, it should of course be removed in the spec file, too.  When I get a chance, I'll build 3.8.0-3 with it completely left out.

Comment 3 J. Randall Owens 2010-01-11 03:41:02 UTC
OK, here are 3.8.0-3 builds, completely free of my own patch:
F11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1913050
F12: https://koji.fedoraproject.org/koji/taskinfo?taskID=1913046

BTW, I am trying to build for rawhide too, but keep getting "could not init mock buildroot", and it's not clear to me why.  So for now, these will have to do.

Comment 4 J. Randall Owens 2010-01-11 04:32:22 UTC
Oh, and as an added bonus, all of the above packages have a modified initscript to comply with the LSB standard, which should take care of old, old Bug 246903.

Comment 5 J. Randall Owens 2010-01-11 05:12:18 UTC
(Two modest corrections to my P.S. in Comment 1: I think it should be Subhodip, not Robert, who can add me to the newer releases at admin.fedoraproject.org, but I don't think he's on the CC list here anyway; and, when I said rawhide, I meant Fedora devel.)

Comment 6 J. Randall Owens 2010-01-11 12:43:22 UTC
OK, I got them to build against target dist-f13, which I think we should be using now instead of rawhide?  Here they are:
w/ HE patch:  https://koji.fedoraproject.org/koji/taskinfo?taskID=1913719
w/o HE patch: https://koji.fedoraproject.org/koji/taskinfo?taskID=1913728

Comment 7 J. Randall Owens 2010-01-14 02:40:18 UTC
Had a little trouble when I installed those, so I fixed the initscript up a bit (forgot to include the HUP signal for reload before), and hopefully these will be better now.  I changed from using entirely different release numbers for the with and without HE tunnel versions, adding a .he for the with now, to make it clearer which is which.  If we go with the "with" version, take that out before the final build, of course.

3.8.0-4 without HE tunnel udpating:
F11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920235
F12: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920239
F13: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920246

3.8.0-4.he with HE tunnel updating:
F11: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920237
F12: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920243
F13: https://koji.fedoraproject.org/koji/taskinfo?taskID=1920250

Comment 8 Robert Scheck 2010-02-21 14:42:58 UTC
Subhodip, ping? Can you please show up? You're the maintainer.

Comment 9 Robert Scheck 2010-02-21 14:53:37 UTC
Randall, can you please provide the SRPM for 3.8.0-4 and 3.8.0-4.he at a more
fix location rather than at a scratch build where it already got purged? I'll
try to look at this, alternatively send me your work via e-mail.

Comment 10 Bug Zapper 2010-03-15 13:44:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Robert Scheck 2010-04-04 10:09:07 UTC
*** Bug 579336 has been marked as a duplicate of this bug. ***

Comment 12 Robert Scheck 2010-05-01 16:59:24 UTC
Already working on that as the package owner seems to be AWOL.

Comment 13 Fedora Update System 2010-05-01 23:21:57 UTC
ddclient-3.8.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc13

Comment 14 Fedora Update System 2010-05-01 23:23:55 UTC
ddclient-3.8.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc12

Comment 15 Fedora Update System 2010-05-01 23:25:46 UTC
ddclient-3.8.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc11

Comment 16 Fedora Update System 2010-05-01 23:26:36 UTC
ddclient-3.8.0-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el5

Comment 17 Fedora Update System 2010-05-01 23:27:00 UTC
ddclient-3.8.0-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el4

Comment 18 Fedora Update System 2010-05-02 19:31:30 UTC
ddclient-3.8.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc13

Comment 19 Fedora Update System 2010-05-02 19:32:21 UTC
ddclient-3.8.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc11

Comment 20 Fedora Update System 2010-05-02 19:32:24 UTC
ddclient-3.8.0-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el5

Comment 21 Fedora Update System 2010-05-02 19:32:58 UTC
ddclient-3.8.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc12

Comment 22 Fedora Update System 2010-05-02 19:33:13 UTC
ddclient-3.8.0-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el4

Comment 23 Fedora Update System 2010-05-03 20:27:17 UTC
ddclient-3.8.0-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ddclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el4

Comment 24 Fedora Update System 2010-05-03 20:27:54 UTC
ddclient-3.8.0-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ddclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.el5

Comment 25 Fedora Update System 2010-05-04 06:02:15 UTC
ddclient-3.8.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ddclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc12

Comment 26 Fedora Update System 2010-05-04 06:04:43 UTC
ddclient-3.8.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ddclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc11

Comment 27 Fedora Update System 2010-05-04 06:24:00 UTC
ddclient-3.8.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ddclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ddclient-3.8.0-1.fc13

Comment 28 Fedora Admin XMLRPC Client 2010-05-29 05:52:47 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 29 Fedora Update System 2010-05-29 11:00:13 UTC
ddclient-3.8.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-2.fc13

Comment 30 Fedora Update System 2010-05-29 11:00:53 UTC
ddclient-3.8.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-2.fc12

Comment 31 Fedora Update System 2010-05-29 11:00:55 UTC
ddclient-3.8.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-2.fc11

Comment 32 Fedora Update System 2010-05-29 11:00:56 UTC
ddclient-3.8.0-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-2.el5

Comment 33 Fedora Update System 2010-05-29 11:01:03 UTC
ddclient-3.8.0-2.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/ddclient-3.8.0-2.el4

Comment 34 Robert Scheck 2010-05-29 11:09:03 UTC
Fixed with ddclient-3.8.0-2

Comment 35 Fedora Update System 2010-06-14 17:07:09 UTC
ddclient-3.8.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Fedora Update System 2010-06-14 17:08:48 UTC
ddclient-3.8.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2010-06-14 17:24:01 UTC
ddclient-3.8.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 38 Fedora Update System 2010-06-22 01:10:15 UTC
ddclient-3.8.0-2.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 39 Fedora Update System 2010-06-22 01:11:46 UTC
ddclient-3.8.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.