Bug 55191 - Installs fail on laptop with Error -3 while decompressing
Installs fail on laptop with Error -3 while decompressing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 16:32 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-26 16:32:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Installing on a Dell Inspiron 7000 (laptop with 440BX chip set 
and 96MB of RAM) using both HTTP and FTP network installs.  

After starting to format the filesystem, the installation dies with:
 install exited abnormally -- received signal 11
 sending termination signals...done
followed by other shutdown information.

Console F4 shows numerous mesages: 
 <6>attempt to access beyond end of device
 <6>01:01: rw=1, want=7010, limit=4608"

ending with 
 <6>attempt to access beyond end of device
 <6>01:01: rw=1, want=5103, limit=4608"
 <4>Error -3 while decompressing!
 <4>c026bb67(792)->c39ea000(4096)
 <4>Error -3 while decompressing!
 <4>c026be7f(26)->c4fb9000(4096)

Isn't device 01:01 memory?

Console F5 shows output from mke2fs 
  Writing inode tables: 3/23




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to install
2.
3.
	

Actual Results:  see description

Expected Results:  it should have installed

Additional info:
Comment 1 Brent Fox 2001-10-26 16:42:41 EDT
This looks like some kind of kernel problem to me.  Changing components.
Comment 2 Bill Nottingham 2001-10-29 14:25:43 EST
That implies that it ran into errors decompressing the cramfs image. Are you
sure your CD image downloaded OK - do the MD5 sums of the images match the ones
on the FTP site?
Comment 3 Need Real Name 2001-10-29 14:44:09 EST
Yes, I matched the MD5 sums first thing after downloading.  If there is a
corruption problem like this, it would have to be in the transfer from the
server machine to the install target. I have tried both HTTP and FTP protocols
using a Redhat 6.2 system as the server machine.

Are there any options on validating the transfers via FTP or HTTP?
Comment 4 Need Real Name 2001-10-31 16:54:07 EST
I have now tried installing off of the hard disk by copying the ISO images over 
to the laptop and using the "Hard Drive" option on the install.  The failure is 
the same.
Comment 5 panu.matilainen 2001-12-17 05:06:35 EST
I'm seeing the same thing here with two computers: one is Compaq M700 and
another Compaq Evo N400C.. The funny thing is that RH7.1 installs on the M700
without any problems and then 7.2 on another M700 complains about "attempt to
access beyond end of device" but still installs & runs just fine.
Comment 6 panu.matilainen 2001-12-18 04:02:41 EST
BTW also Compaq Evo 600 shares the same problem. All the cases install properly
with NFS installs, but FTP and HTTP installations fail.
Comment 7 Robert Spier 2002-03-24 01:16:28 EST
I'm seeing this as well on my IBM ThinkPad X22.  I've been running in circles
for two days trying to track it down.
I'm doing a PXE boot and then HTTP install off out loopback mounted ISO images.
(PXE server and HTTP server are RH7.2, Installation fails with 7.2 and Skipjack.)
Comment 8 Robert Spier 2002-05-09 01:52:26 EDT
Reproduced on my thinkpad X22 with RH7.3 - same symptoms.
Comment 9 Bugzilla owner 2004-09-30 11:39:13 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.