Bug 55196 - [binary only module] Output of sound through Esound causes hard lockup
[binary only module] Output of sound through Esound causes hard lockup
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 18:24 EDT by Alvin Thompson
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 12:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alvin Thompson 2001-10-26 18:24:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011023

Description of problem:
accessing hard disk while using Aureal Vortex drivers (see freshmeat)
results in lockup and severe corruption of hard disk. journaling
(obviously) does no good in this case. i recovered around 70 percent of
data drive (20GB of 29) after around 24 hours using various recovery tools.
for the average user this would have been a total loss.

my guess is that this is an interupt-sharing problem. i believe the Vortex
card may share an interrupt with the Promise IDE controller. however,
moving the card to another slot and resetting configuration data had no
affect (problem still reproduceable). problem did not occur with my
previous Linux box (also contains a Vortex card), and, since it was running
Roswell, one can assume it is the difference in motherboard hardware. the
current Linux box used to be my Win2000 box, where there were no problems
with the vortex.

to the very knowledgeable, the Aureal Vortex is the preffered card as the
amplification on other cards (especially Creative cards) produces
unnacceptable clipping and crossover distortion. in addition, the Vortex II
has an on-board passive equalizer. no one is in the same ballpark as the
Vortex for fidelity.

this problem needs to be fixed quickly.

thanks,
alvin thompson




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH7.2
2.install Aureal Vortex OSS driver 1.1.2
3.produce continuous sound (i.e. play MP3)
4.access hard disk (click on Mozilla icon)

Actual Results:  lockup/corruption. hard disk can be corrupted even if no
write operations were occurring.

locks up every time. corrupts data most of the time.


Additional info:

current Linux box (problem):
   Redhat 7.2 (2.4.7)(Enigma)
   Asus A7V (Via KT133 chipset)
       Athlon 1GHz
       512MB
       AGP
           Nvidia GeForce 2 GTS 32MB
       PCI
           Aureal Vortex II (AU8830A2)
           Tulip 21140 (eth0)
           Tulip 21041 (eth1)
       main IDE system
           primary
               master - Maxtor 20GB (root)
               slave - Western Digital 3.1 GB (swap)
           secondary
               master - Creative 5x DVD ROM
               slave - Acer CDRW (10x/4x/32x)
       Promise ATA100 IDE controller (NOT set to RAID)
           primary
               master - Maxtor 30GB (mounted as /data) ***corrupted***

previous Linux Box (ran fine):
   Redhat 7.19x (Roswell)
   FIC(?) K6XV3+ (Via MVP3(?) chipset)
       K6-2 400MHz
       192MB
       AGP
           Riva TNT2 32MB
       PCI
           Aureal Vortex II (AU8830A2)
           Tulip 21140 (eth0)
           Tulip 21041 (eth1)
       main IDE system
           primary
               master - Maxtor 30GB (root)
               slave - Western Digital 3.1 GB (swap)
           secondary
               master - generic 24x CD ROM
Comment 1 Alvin Thompson 2001-10-29 19:32:31 EST
placing the card in slot 3, which does not share interrupts, does not help.
/proc/interrupts looks fine. the only thing sharing interrupts now are netwark
cards. i guess it's not an interrupt problem.
Comment 2 Arjan van de Ven 2001-11-03 13:04:59 EST
Well the binary only module from aureal was written for 2.2; the 2.4 interrupt
mechanisms are quite different so I'm not really suprised it doesn't work....
Comment 3 Alvin Thompson 2001-11-03 16:02:04 EST
interesting that there are vortex game port drivers built into the kernel but no sound 
drivers...
Comment 4 Arjan van de Ven 2001-11-03 16:15:01 EST
That's because that driver is open source; most likely Aureal gave out specs...
they never did this for the sound part unfortionatly.
Comment 5 Alvin Thompson 2001-11-15 06:32:00 EST
problem also happens using SBLive sound card, although it takes much longer
(mean time between lockups is around 36-48 hours of constant disk usage and
sound output). this may be a different bug as it takes much longer and the hard
drive doesn't seem to be as corrupted as with Vortex. setting the output pluggin
in XMMS to OSS instead of ARTS (or ESS for the not-so-bright) seems to make the
problem more likely. i have done a clean install, swapped slots/interrupts,
recompiled the kernel, removed the NVidia driver, and removed the Promise IDE
driver and the hard disk. Problem still occurs. as you can see from the
description above, this is pretty much a vanilla system. so if it can happen to
me, it can happen to anyone. since the problem also occurs with the
relatively-common SBLive and involves loss of data i recommend increasing the
priority to something more appriate. feel free to contact me for more information.
Comment 6 Alvin Thompson 2002-01-27 05:59:26 EST
there are actually two different problems which cause the lockups: there is the
vortex problem, as above, and also if any program tries to output sound through
ESD it causes occasional hard lockups, although not as likely to cause disk
corruption. the latter problem happens regardless of the type of sound card.

i have two systems and the latter problem occurs on both. the only 3 things they
have in common are assus a7v motherboards (different revisions), athlon
processors (different speeds), and maxtor hard drives (different sizes).
Comment 7 Alvin Thompson 2002-01-27 06:11:21 EST
forgot to mention both computers run fine with Mandrake Linux and its version of
esound.
Comment 8 Havoc Pennington 2002-02-11 17:02:34 EST
How did this end up on esound instead of kernel?
Comment 9 Alan Cox 2003-06-08 12:58:59 EDT
SB Live should be fixed. The binary stuff is a WONTFIX. Please re-open the bug
if current errata havent solved it for you with SB Live

Note You need to log in before you can comment on or make changes to this bug.