Bug 55200 - run fails when executed
run fails when executed
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2 (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 20:04 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 07:38:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/src/cvs/printconf/util/printconf_gui.py (63.74 KB, text/plain)
2001-11-02 12:23 EST, Crutcher Dunnavant
no flags Details
Debug output according to instructions (2.95 KB, patch)
2001-11-04 11:14 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2001-10-26 20:04:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010929

Description of problem:
Since you @RH are only interested in packages not running (not patches for
spec files etc, see earlier bug logs), here is one about execution probs. I
know 7.2 is out, but maybe rawhide should differ (now it does, earlier it
did not). The latest rawhide is terribly broken wrt building from source
but who cares when 7.2 is out. (there is always debian unstable).

Version-Release number of selected component (if applicable):
printconf-0.3.51-1

How reproducible:
Always

Steps to Reproduce:
1. run
2.
3.

Additional info:

Traceback (most recent call last):
  File "/usr/sbin/printconf-gui", line 8, in ?
    printconf_gui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_gui.py", line 2167, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_gui.py", line 2135, in gui_main_run
    gtk.mainloop()
  File "/usr/lib/python2.2/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python2.2/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/printconf/util/printconf_gui.py", line 2015, in
qld_on_new_button_clicked
    nqd_run()
  File "/usr/share/printconf/util/printconf_gui.py", line 352, in nqd_run
    nqd_init()
  File "/usr/share/printconf/util/printconf_gui.py", line 368, in nqd_init
    nqd.driver.node_dict = driver_ctree(nqd.driver.driver_ctree)
  File "/usr/share/printconf/util/printconf_gui.py", line 741, in driver_ctree
    make_node = ctree.insert_node(None, None, [make], is_leaf = 0)
  File "/usr/lib/python2.2/site-packages/gtk.py", line 1357, in insert_node
    is_leaf, expanded)
TypeError: sequence item not a string
Comment 1 Crutcher Dunnavant 2001-11-02 12:20:47 EST
umm. odd. This does not happen for me, so we have to debug on your system.

Attached is a replacement for /usr/share/printconf/util/printconf_gui.py, please
install it, and edit /usr/sbin/printconf-gui to change the top line from:

 #!/usr/bin/python -0

to

 #!/usr/bin/python


Then, run printconf-gui as:

 printconf-gui 2> debug.out

and attach debug.out after it crashes.
can you try running this with the attached version of printconf_gui.py? you wi
Comment 2 Crutcher Dunnavant 2001-11-02 12:23:48 EST
Created attachment 36221 [details]
/usr/src/cvs/printconf/util/printconf_gui.py
Comment 3 Need Real Name 2001-11-04 11:14:25 EST
Created attachment 36346 [details]
Debug output according to instructions
Comment 4 Tim Waugh 2002-01-25 09:54:47 EST
This is really odd; the 'sequence item' it complains about is 'Alps', which
plainly _is_ a string!

Can you attach your /etc/alchemist/namespace/printconf/local.adl file please?

There have been printing updates released; have you tried those, and did they
help?  If not, could you please try the packages at
<ftp://people.redhat.com/twaugh/errata-candidate/> and let me know if they help
any?

Thanks.
Comment 5 Tim Waugh 2002-01-29 07:38:16 EST
Does wrapper 'make', 'model', and 'driver' in str() calls help?

I bet it's because of python's 'unicode' type.
Comment 6 Tim Waugh 2002-01-29 08:08:05 EST
I'm pretty sure this is fixed in pygtk2-1.99.6-3.  Please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.