Bug 55201 - smb_panic while printing to samba server
smb_panic while printing to samba server
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 21:05 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 08:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-26 21:05:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I have a box that has been running Redhat linux for serveral years now.  I
installed 6.1 and have since upgraded to 6.2, 7.0, 7.1 and now 7.2.  Samba
has worked fine for all installations up to now.

The server (manny) can still share file shares with no problem and printer
shares can be browsed with no problem.  When something is printed to the
share, however, nothing is printed and the following error is reported in
/var/logs/samba/meche.log (meche was the machine that was trying to print)

[2001/10/26 16:27:12, 0] lib/util.c:smb_panic(1101)
  PANIC: internal error
[2001/10/26 16:57:08, 0] lib/fault.c:fault_report(40)
  ===============================================================
[2001/10/26 16:57:08, 0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 12582 (2.2.1a)
  Please read the file BUGS.txt in the distribution
[2001/10/26 16:57:08, 0] lib/fault.c:fault_report(43)
  ===============================================================
[2001/10/26 16:57:08, 0] lib/util.c:smb_panic(1101)
  PANIC: internal error
[2001/10/26 16:57:09, 0] lib/fault.c:fault_report(40)
  ===============================================================
[2001/10/26 16:57:09, 0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 12585 (2.2.1a)
  Please read the file BUGS.txt in the distribution
[2001/10/26 16:57:09, 0] lib/fault.c:fault_report(43)
  ===============================================================
[2001/10/26 16:57:09, 0] lib/util.c:smb_panic(1101)
  PANIC: internal error


Version-Release number of selected component (if applicable):
samba-2.2.1a-4

How reproducible:
Always

Steps to Reproduce:
1.allow all printers to be shared in /etc/samba/smb.conf:
[global]
   printcap name = /etc/printcap
   load printers = yes
[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = yes
   printable = yes
   public = yes
   writable = yes
   create mode = 0700

2.Browse available printer shares and attempt to print (I'm using a win98
box to browse and print)

3.Note print failure (windows dialog saying print failed) and examine
server logs
	

Additional Information

A complete copy of my smb.conf can be found at:
http://www.kleemann.org/crap/smb.conf
Comment 1 jwitford 2001-10-31 08:21:03 EST
This has been fixed in the development version under CVS.
There is a SEGV because of pointer pointing to subsequently free'ed memory.
Here is a patch:

--- samba-2.2.1a/source/smbd/sec_ctx.c.segv	Fri Jul  6 12:02:03 2001
+++ samba-2.2.1a/source/smbd/sec_ctx.c	Thu Nov  1 00:03:20 2001
@@ -356,7 +356,7 @@
 	current_user.gid = gid;
 	current_user.ngroups = ngroups;
 	current_user.groups = groups;
-	current_user.nt_user_token = token;
+	current_user.nt_user_token = ctx_p->token;
 }
 
 /****************************************************************************
Comment 2 Trond Eivind Glomsrxd 2001-10-31 12:19:12 EST
This patch seems to already be included in samba 2.2.2-1, available from Rawhide.
Comment 3 Need Real Name 2001-11-01 00:04:21 EST
Updating the 7.2 samba SRPM with the above patch, recompiling, and reinstalling,
fixed the problem.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.