Bug 552152 - Guest kernel panic when formatting floppy
Guest kernel panic when formatting floppy
Status: CLOSED DUPLICATE of bug 653324
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-04 02:48 EST by Cao, Chen
Modified: 2013-01-09 17:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 08:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the calltrace screenshot (21.04 KB, image/png)
2010-01-04 02:52 EST, Cao, Chen
no flags Details
rhel5.6 guest panic when testing floppy (21.12 KB, image/png)
2011-01-27 03:08 EST, Cao, Chen
no flags Details

  None (edit)
Description Cao, Chen 2010-01-04 02:48:36 EST
Description of problem:
Guest got kernel panic with calltrace when formatting floppy.


Version-Release number of selected component (if applicable):
kvm-83-140


How reproducible:
5%


Steps to Reproduce:
1. start vm with command

qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/tests/kvm/images/RHEL-Server-5.4-PAE-virtio.raw,if=virtio,cache=writethrough,boot=on -net nic,vlan=0,model=virtio,macaddr=00:AE:8F:CE:25:00 -net tap,vlan=0,ifname=virtio_0_6001,script=/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 4096 -smp 2 -fda /tests/kvm/images/test_floppy.img -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -vnc :0

2. after guest started up, login to guest and execute commands:

mkfs -t ext3 /dev/fd0
mount /dev/fd0 /mnt/    # timeout when execute this command

3. calltrace appears


  
Actual results:
guest os died with kernel panic


Expected results:
mount the floppy successfully


Additional info:
1. host kernel
# uname -r
2.6.18-183.el5

2. this problem happens most when using
RHEL-Server-5.4-PAE.virtio_nic.virtio_blk

and also tested and found this on
RHEL-Server-5.4-32bit.virtio_nic.virtio_blk
RHEL-Server-5.4-64bit.virtio_nic.virtio_blk
Comment 2 Cao, Chen 2010-01-04 02:52:32 EST
Created attachment 381495 [details]
the calltrace screenshot

the calltrace after the command "mount"
Comment 8 RHEL Product and Program Management 2011-01-11 15:46:18 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-01-11 17:48:35 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 Cao, Chen 2011-01-27 03:08:11 EST
Created attachment 475553 [details]
rhel5.6 guest panic when testing floppy
Comment 13 Gleb Natapov 2011-05-30 08:25:25 EDT

*** This bug has been marked as a duplicate of bug 653324 ***

Note You need to log in before you can comment on or make changes to this bug.