This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 552250 - Windows virtio block driver performs poorly on small size requests. In addition, cpu usage on the quest side is very high while handling write requests.
Windows virtio block driver performs poorly on small size requests. In additi...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-01-04 08:35 EST by Vadim Rozenfeld
Modified: 2013-01-09 17:09 EST (History)
6 users (show)

See Also:
Fixed In Version: kvm-83-144.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 13:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
performance testing results (83.50 KB, application/octet-stream)
2010-01-05 03:00 EST, Vadim Rozenfeld
no flags Details
retest result. (392.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-01-11 03:51 EST, lihuang
no flags Details

  None (edit)
Description Vadim Rozenfeld 2010-01-04 08:35:24 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Vadim Rozenfeld 2010-01-05 03:00:44 EST
Created attachment 381714 [details]
performance testing results
Comment 3 Dor Laor 2010-01-05 04:15:27 EST
Here is a private brew build for perf team to test:
https://brewweb.devel.redhat.com/getfile?taskID=2171566&name=kvm-83-143.el5.x86_64.rpm
Comment 10 lihuang 2010-01-11 03:51:46 EST
Created attachment 382938 [details]
retest result.

Atthched please find the result of *full* test.

finished run test on both kvm-83-140.el5 and kvm-83-144.el5.

test 100% random read and write.
test block size = 512b,1k,2k,4k,8k,16k,32k,64k
test queue depth = 1,2,4,8,16,32,64


the result shows we don't have an evident throughput improvement when write disk. --> Chart 3.5 and Chart 3.6. ( but at least no evident performance regression :) )

the read performance has some enhance ---> Chart 3.1 and Chart 3.3

and the CPU usage has a large improvement, especially on writing.  --> Chart 3.6 and Chart 3.8


+++++++++++++++++ Test env ++++++++++++++++++
DELL OPTIPLEX 760.
 Intel(R) Core(TM)2 Quad CPU    Q9400  @ 2.66GHz
 *4 cores
 8gb ram

kernel 2.6.18-182.el5
kvm    kvm-83-140.el5
       kvm-83-144.el5

Guest window 2008 R2.

CLI :  /usr/libexec/qemu-kvm -m 2048 -smp 2 -drive file=/root/win2k8-r2-virtio.raw,if=virtio,boot=on,werror=stop -usb -usbdevice tablet -monitor stdio -vnc :1 -net nic,macaddr=00:21:9B:01:02:01,modle=virtio -net tap -rtc-td-hack -uuid c254380c-e301-4564-acf7-3679d4f509a8 -drive file=/root/test.raw,if=virtio -boot c

the virtual disk (test.raw) is on local disk.
raw format.

no other load on guest/host.
+++++++++++++++++ Test env ++++++++++++++++++
Comment 14 Dor Laor 2010-02-17 09:58:10 EST
In https://brewweb.devel.redhat.com/taskinfo?taskID=2264563 you can find new kvm-83-158.el5.x86_64.rpm  with an option to set the queue depth of the physical storage to.

So you should add -drive file=,...,x-queue-depth-suppress-notify=STORAGE_QUEUE_DEPTH

QE/Perf we need your help with it.
Without the flag you get the regular behaviour.
Comment 21 Vadim Rozenfeld 2010-06-30 13:09:35 EDT
x-queue-depth-suppress-notify patch was reverted. 
The problem wasn't solved, and the status is still "assigned".
Comment 35 RHEL Product and Program Management 2011-01-11 15:54:54 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 36 RHEL Product and Program Management 2011-01-11 17:48:43 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.