Bug 55230 - Grub refuses to load RHL 7.2 and W2k
Grub refuses to load RHL 7.2 and W2k
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-27 16:29 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 12:39:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Grub config file that is not working (621 bytes, text/plain)
2001-10-27 16:30 EDT, Need Real Name
no flags Details
Lilo config file that is working (257 bytes, text/plain)
2001-10-27 16:35 EDT, Need Real Name
no flags Details
Disk information (hdparm -i and parted print) (1.66 KB, text/plain)
2001-10-27 16:37 EDT, Need Real Name
no flags Details
device.map (105 bytes, text/plain)
2001-10-29 23:22 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-27 16:29:20 EDT
Description of Problem:
After a fresh install of Enigma on a Gateway Pentium II 300 MHz, Grub comes
up with a menu and a splashfile, but does not want to load either of the
operating systems on the machine.  Lilo works perfectly for either.

See attachments for system info.

Version-Release number of selected component (if applicable):
0.90

How Reproducible:
Every time Grub is the boot loader.

Steps to Reproduce:
1. Run grub-install
2. Reboot


Actual Results:
Error messages are as follows:
For Enigma: 
  Booting 'Red Hat Linux (2.4.7-10)'

root (hd1,4)
 Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.4.7-10 ro root=/dev/hde5
   [Linux-bzImage, setup=0x1400, size=0xc2714]

For Win2k:
  Booting 'Windows'

rootnoverify (hd0,0)
chainloader +1

Error 25: Disk read error

Press any key to continue...


Expected Results:
Grub loads Enigma and Win2k correctly.

Additional Information:
Comment 1 Need Real Name 2001-10-27 16:30:51 EDT
Created attachment 35264 [details]
Grub config file that is not working
Comment 2 Need Real Name 2001-10-27 16:35:49 EDT
Created attachment 35265 [details]
Lilo config file that is working
Comment 3 Need Real Name 2001-10-27 16:37:27 EDT
Created attachment 35266 [details]
Disk information (hdparm -i and parted print)
Comment 4 Jeremy Katz 2001-10-29 14:59:48 EST
Can you also attach your /boot/grub/device.map?
Comment 5 Need Real Name 2001-10-29 23:22:33 EST
Created attachment 35581 [details]
device.map
Comment 6 Jeremy Katz 2001-10-31 17:40:19 EST
Which drive is set up as your first drive in your BIOS?
Comment 7 Need Real Name 2001-10-31 17:59:21 EST
/dev/hda (ide0, disk0) is setup as the first boot device.  I actually have no 
opportunity to set it to /dev/hde (ide2, disk0) (the BIOS only allows disks on 
the internal (motherboard) ide slots to be selected for boot).
BTW, I am installing both GRUB and lilo on /dev/hda  (i.e. the MBR).
Comment 8 Need Real Name 2002-01-19 11:13:59 EST
There is a similar problem in one machine I installed RH 7.2 to...

Grub cannot boot w2k from NTFS partition which is located in (hd0,0), and dislays 
Error 25: Disk read error.
Linux, which is installed to another disk (hd1,6) boots fine.

I found a way to make windows boot: 
When the boot menu appears, press 'C'
run command 'geometry (hd0)'
then press esc to get back to menu
now, when windows is selected from the menu, it boots normally!

The really interesting part is that the command 'geometry (hd0)' must be run by 
hand. If it's put in the menu.lst under 'title Windows', it won't work.
Also, if you type all the commands by hand (geometry (hd0), rootnoverify (hd0,0), 
chainloader +1, boot) the disk read error message appears.

I currently have no access to that machine, so I can't get more detailed info.
I'll try to get the info soon.

Here's something I remember:
Grub is installed on MBR of hda
GRUB versions tried: RedHat 7.2 default and grub-0.91-0.20020102cvs from 
rawhide, both show just the same error
hda is some 20GB IDE and hdb is 40GB IDE disk
Machine is 1000MHz Athlon and mb has probably a VIA chipset.
Comment 9 Jeremy Katz 2002-01-21 20:23:13 EST
Do the test packages at http://people.redhat.com/katzj/grub/ work any better? 
(install the packages, then run `/sbin/grub-install /dev/hda`)
Comment 10 Jeremy Katz 2002-03-08 16:09:24 EST
Closing due to inactivity.  If you have further information based on the updated
packages, feel free to reopen this report.
Comment 11 Need Real Name 2002-03-09 19:04:58 EST
Sorry for not getting back to you on this - too many work and personal issues.

Just tried the test package and it now loads Enigma fine, but still gives the 
exact same error on loading Win2k.
Comment 12 Jeremy Katz 2002-12-29 01:11:13 EST
Does this still occur with 0.92 or the 0.93 package now available at
http://people.redhat.com/~katzj/grub/.  I've yet to see this on any machine I
have access to or see other reports of the problem
Comment 13 Need Real Name 2002-12-29 09:41:38 EST
The hardware configuration of this machine changed recently (the disk on hde 
failed).  I replaced it with a completely different disk and put it on hdb.  I 
installed 8.0 on the new disk with grub and it worked fine except that it took 
about 30 seconds to execute stage 1.5.  But then I had trouble with Win2k on 
hda and decided to turn it into a linux only machine.  / and /boot is now on 
hda and /home on hdb.  
So, in the end it seems to have been some peculiar hardware interaction.
Comment 14 Jeremy Katz 2002-12-29 12:39:38 EST
Due to lack of reproducibility, closing as WORKFORME.  If you can reproduce on
different hardware, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.