Bug 55232 - SMP, apm=power-off freezes, EXT3
SMP, apm=power-off freezes, EXT3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-27 17:26 EDT by jouni
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-27 17:46:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jouni 2001-10-27 17:26:36 EDT
Description of problem:
I tried first time to make power off to work on my SMP machine (ASUS
P3C-D, Dual PIII 750MHz, 512 MB RDRAM).  I added apm=power-off to 
grup.conf.
When I try to boot the kernel freezes totally after following lines on 
terminal:

    apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
    apm: disabled -APM is not SMP safe (power off active).

This happens both with original and errata 2.4.9 kernel.


Another problem:

When I booted my box after the frozed boot-up, the fsck was the same slow 
check during next boot as with ext2.  (Just double-checked /proc/mounts:  
all ext3.)

Only non-standard procedure during boot was editing the boot command 
inside grub to boot without the apm=...

Best regards,

Jouni

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add apm=power-off to boot command in grub.conf (or lilo.conf)
2. Boot with same hardware as I have..
3.
	

Actual Results:  kernel freezes

Expected Results:  normal boot.

Additional info:
Comment 1 Arjan van de Ven 2001-10-27 17:46:32 EDT
This looks like your bios is totally broken in this respect ;(

This is not that uncommon, and is the reason poweroff is disabled by default on
smp....

Note You need to log in before you can comment on or make changes to this bug.