Bug 552380 - SIGSEGV in "IA__g_cclosure_marshal_VOID__INT" in /usr/share/avant-window-navigator/applets/animal-farm/animal-farm.py
Summary: SIGSEGV in "IA__g_cclosure_marshal_VOID__INT" in /usr/share/avant-window-navi...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: awn-extras-applets (Show other bugs)
(Show other bugs)
Version: 12
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b474ac689723ee87267df73f654...
Keywords:
: 552394 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-04 20:57 UTC by Laurent Forthomme
Modified: 2010-05-09 11:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-09 11:21:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.27 KB, text/plain)
2010-01-04 20:57 UTC, Laurent Forthomme
no flags Details

Description Laurent Forthomme 2010-01-04 20:57:14 UTC
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: python /usr/share/avant-window-navigator/applets/animal-farm/animal-farm.py --uid=1250770442 --window=75497526 --orient=0 --height=42
component: python
executable: /usr/bin/python
kernel: 2.6.31.9-174.fc12.i686
package: python-2.6.2-2.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Laurent Forthomme 2010-01-04 20:57:24 UTC
Created attachment 381643 [details]
File: backtrace

Comment 2 Dave Malcolm 2010-01-04 21:19:24 UTC
Thank you for reporting this bug.

Unfortunately, that stack trace is not as useful as it could be in determining the cause of the crash, because it is only a partial symbolic stack trace. In order to get a more full symbolic stack trace, additional debuginfo packages need to be installed. In order to accomplish this, you can run the command:
  debuginfo-install avant-window-navigator
Please see http://fedoraproject.org/wiki/StackTraces for more information about stack traces.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What version of awn-extras-applets do you have installed?

Looking at the backtrace, it looks like the problem occurred in the program's single thread seomwhere inside /usr/lib/libawn.so.0 in response to IA__g_cclosure_marshal_VOID__INT

Reassigning component from "python" to "awn-extras-applets"

Comment 3 Dave Malcolm 2010-01-04 21:49:01 UTC
*** Bug 552394 has been marked as a duplicate of this bug. ***

Comment 4 leigh scott 2010-05-09 11:21:31 UTC
Closed, hopefully fixed in version 0.4.0


Note You need to log in before you can comment on or make changes to this bug.