Bug 552382 - SIGSEGV in "on_size_changed" in /usr/share/avant-window-navigator/applets/thinkhdaps/thinkhdaps.py
SIGSEGV in "on_size_changed" in /usr/share/avant-window-navigator/applets/thi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: awn-extras-applets (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
abrt_hash:1659582685005ac331b28da86b5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-04 16:02 EST by Jean Reis
Modified: 2010-05-09 07:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-09 07:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.33 KB, text/plain)
2010-01-04 16:02 EST, Jean Reis
no flags Details

  None (edit)
Description Jean Reis 2010-01-04 16:02:26 EST
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: python /usr/share/avant-window-navigator/applets/thinkhdaps/thinkhdaps.py --uid=1262638903 --window=73421104 --orient=0 --height=48
component: python
executable: /usr/bin/python
kernel: 2.6.31.9-174.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Jean Reis 2010-01-04 16:02:29 EST
Created attachment 381644 [details]
File: backtrace
Comment 2 Dave Malcolm 2010-01-04 16:22:00 EST
Thank you for reporting this bug.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What version of awn-extras-applets do you have installed?

Looking at the backtrace, it looks like the problem occurred in the program's single thread in on_size_changed handling a "com-google-code-Awn-AppletManager-SizeChanged" DBus event.

Reassigning component from "python" to "awn-extras-applets"
Comment 3 Jean Reis 2010-01-04 19:12:26 EST
Hello Dave,

> How reproducible is this problem? 

So far I've only experienced it once, but then again I don't use AWN extensively (just trying it out to see if I like it, so to speak).


> If you run the program from a terminal, is
> an error message printed?

There are no startup errors, but after causing some resizing of AWN (which I understand may be the cause of the crash), the following is printed (once for every resize event, it seems):

(awn-applet-activation:18285): Gdk-WARNING **: XID collision, trouble ahead

(awn-applet-activation:18285): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed


> What version of awn-extras-applets do you have installed?

awn-extras-applets-0.3.2.1-8.fc11.x86_64


I'll be glad to provide more info if needed.
Comment 4 leigh scott 2010-05-09 07:20:47 EDT
Closed, hopefully fixed in version 0.4.0

Note You need to log in before you can comment on or make changes to this bug.