Bug 552385 - [abrt] crash in Miro-2.5.4-1.fc12
Summary: [abrt] crash in Miro-2.5.4-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7957a69b
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-04 21:06 UTC by Marcel
Modified: 2010-09-15 05:51 UTC (History)
3 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:03:21 UTC


Attachments (Terms of Use)
File: backtrace (837 bytes, text/plain)
2010-01-04 21:06 UTC, Marcel
no flags Details

Description Marcel 2010-01-04 21:06:57 UTC
abrt 1.0.2 detected a crash.

backtrace
-----
Summary: TB7957a69b gstreamerrenderer.py:288:on_sync_message:TypeError: object of type `GstSDLVideoSink' does not have property `force-aspect-ratio'

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/plat/renderers/gstreamerrenderer.py", line 288, in on_sync_message
    imagesink.set_property('force-aspect-ratio', True)
TypeError: object of type `GstSDLVideoSink' does not have property `force-aspect-ratio'

Local variables in innermost frame:
self: <miro.plat.renderers.gstreamerrenderer.VideoRenderer instance at 0x2d6c518>
bus: /GstBus:bus1 (gst.Bus)
message: <gst.Message prepare-xwindow-id; from sdlvideosink0 at 0x7f2f5c003ae0>
message_name: prepare-xwindow-id
imagesink: /GstPlayBin:player/GstBin:vbin/GstGConfVideoSink:sink/GstBin:bin5/GstSDLVideoSink:sdlvideosink0 (__main__.GstSDLVideoSink)

cmdline: /usr/bin/python /usr/bin/miro.real 
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.31.9-174.fc12.x86_64
package: Miro-2.5.4-1.fc12
uuid: 7957a69b

Comment 1 Marcel 2010-01-04 21:06:59 UTC
Created attachment 381650 [details]
File: backtrace

Comment 2 Alex Lancaster 2010-01-05 22:35:03 UTC
Can you describe what you were doing?  Can you describe the exact conditions to reproduce this?   If you can't reproduce this reliably, it'll be almost impossible to fix.

Comment 3 Marcel 2010-01-07 18:43:42 UTC
As i remember, nothing special. Just watching video.
If i remember well, Miro was not really crashed because i continue to use it after the crash alert.

Comment 4 Alex Lancaster 2010-01-13 23:08:47 UTC
Will: any ideas?  Is this related to any of the other open bugs?

Comment 5 Alex Lancaster 2010-07-18 08:49:45 UTC
Reporter: can you still reproduce this in the current version of Miro: 3.0.2?  If not, or if I don't hear a response within 1 week, I'll close this bug.  If you can reproduce you're always free to re-open it.

Comment 6 will kahn-greene 2010-07-18 13:04:37 UTC
The problem here is that the version of GstSDLVideoSink from GStreamer doesn't support the force-aspect-ratio property.  When Miro goes to set that property, it kicks up the stack trace above.

This should be a problem with Miro 3.0, 3.0.1 and 3.0.2 when used with the same version of GstSDLVideoSink--the code in Miro is the same.

I think that plugin is in gstreamer-bad plugins.

If there is no version of GstSDLVideoSink that provides this property, then we should assign this bug to GStreamer and hope someone implements it.

If there is a version of GstSDLVideoSink that provides this property, then I think the solution is for the packaging to require at least that version of gstreamer-plugins-bad.

Marcel: What version of gstreamer-plugins-bad are you running?  (or whatever it's called in Fedora)

Comment 7 Fedora Update System 2010-08-29 17:18:42 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 8 Fedora Update System 2010-08-29 17:25:48 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 9 Fedora Update System 2010-08-29 17:29:54 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 10 Fedora Update System 2010-08-30 19:40:25 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 11 Fedora Update System 2010-09-14 05:01:16 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-09-15 05:33:16 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-09-15 05:48:25 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.