Bug 5524 - Machine hangs during post-install configuration
Machine hangs during post-install configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 18:28 EDT by anthony_placilla
Modified: 2008-05-01 11:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 13:20:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anthony_placilla 1999-10-04 18:28:53 EDT
KDE workstation install. HDA partitioned 545mb for / 80mb
for swap. HDC partitioned 150mb for /home 490mb for /usr.
Pentium 133, 32mb ram, ATI Mach32 vid card. cdrom is HDB.

Install hangs at post install configuration.

useradd: cannot rewrite password file
exception in thread thread-4:

python traceback follows:

File "/usr/lib/python1.5/threading.py", line 376, in
__bootstrap self.run()

File
"/mnt/redhat/comps/install/6.1/i386/RedHat/instimage/usr/lib/python1.5/site-packages/iw/progress.py",
line 16, in run

File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/todo.py",
line 1551, in doInstall
 self.createAccounts ()

File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/todo.py",
line 1282, in createAccounts
	stdout = devnull

File
"../../../RedHat/instimage/usr/lib/python1.5/site-package/iutil.py",
line 33, in execWithRedirect
	raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/chfn can not be run

------- Additional Comments From   10/14/99 16:51 -------
I had my RH6.1 also crash (in a spectacular Python error message) just
after the packages install and before post-install. Apparently it
happens in the graphic install also but I didn't see it, just wondered
why my NIC didn't work.

Then I re-did the install (clean, custom) in text mode and saw the
error.

As a result, I had to manually fix what had not been done: copy hosts,
resolv.conf, ifcfg-eth0 from my old 5.2 installation (lucky me!), fix
up the empty keyboard pointer file (for console mode) and edit
XF86Config (for X) in order to get Finnish keyboard localization.
(After running XConfigurator, as the Red Hat X configuration produced
was flakey and lost the mouse from time to time. S3 chip set, three
button generic serial mouse on ttyS0)

One day later I had what a half hour install ought to have produced.
This is giving Linux a bad name. Imagine if it had been my granny
doing the install ;-)

But KDE/Gnome look good.

martin.vermeer@liisa.pp.fi
Comment 1 Jay Turner 1999-10-22 13:57:59 EDT
Is it possible that you ran out of disk space and that is why the
machine was not able to rewrite the password file?  I am not able to
replicate the situation in the lab, and without having the package
list that you installed, I cannot truly replicate.
Comment 2 bsharpe 1999-11-17 11:54:59 EST
I also have this problem, but I don't have enough experience to fix it like the
other user did.

RH 6.1 Professional version out of the box.
200 Mhz PentiumPro - Supermicro MB - latest bios
1 CD-ROM, 1 Floppy, 2 HD's (IDE) - (old, but both recently formatted)
160M of RAM, PS/2 Mouse, Trident Videocard

I've tried every combination of installs possible using the latest patches from
RH.
Novice, Text, Expert - Server, Gnome Wkstn, KDE Wkstn
Always the same error, just after installing all the packages the machine
stops. In GUI mode, it will sit there until i hit any key or move the mouse.
Then it says "Post Install Configuration" now it's really hung.
A switch over to the terminal window (CTrl-Alt-F1) shows a Python error
message. (FYI: many examples of this error text can be found in
linux.redhat.install)
Exception Occurred
File "/usr/bin/anaconda", line 225, in ? intf.run(todo, test = test)
File "/tmp/updates/text.py", line 1009, in run rc = apply( Step[1](), step[2])
File "/tmp/updates/test.py", line 572, in __call__ if todo.doInstall ():
File "/tmp/updates/todo.py", line 1587, in do Install self.writeTimezone()
File "/tmp/updates/todo.py", line 487, in writeTimezone self.instPath
+ "/etc/localtime")
File "/tmp/updates/iutil.py", line 105, in copyFile f = os.open(source,
os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/sysimage/usr/share/zoneinfo/US/Pacific'

- - - -
I've tried every time zone setting as well.
Comment 3 gabers 1999-12-03 12:57:59 EST
I also have the SAME problem!

My system is a:
PIII 500MHz w/ 128MB of SDRAM w/ a 1.6GB hd being used to install to

There was python errors up the ...

What's the deal with this, and why are only certain people experiencing this?
Could it be the ISO?
Comment 4 Mahendra Kothari 1999-12-16 08:20:59 EST
I have similar problem.

Why RedHat does not tell that you can do alt+ctl+f1 to go to
text window.

Is there any fix for this.

I have wasted about 20 hours on this.

I am buying Microsoft stock.  Red hat people have to be reborn
again to popularize Linux.
Comment 5 Jacques Limpens 2000-01-03 14:58:59 EST
Okay, and I'm another stupid that encouters this problem. Yes, I tried the boot-
RHEA-1999:044 and updates-RHEA-1999:045 images, but with no postive result. (On
the same machine Windows NT 4.0 Workstation + Windows 2000 Professional RC2
have been installed in NTFS partitions, but 2 GB is left for Linux.)

Python reports about the same problems as "Martin Vermeer" and bsharpe report:

File "/usr/lib/python1.5/threading.py", line 376, in
__bootstrap self.run()
File "/tmp/updates/iw/progress.py", line 16, in run
rc=self.todo.doInstall ()
File "/tmp/updates/test.py", line 572, in __call__ if todo.doInstall ():
File "/tmp/updates/todo.py", line 1587, in do Install self.writeTimezone()
File "/tmp/updates/todo.py", line 487, in writeTimezone self.instPath
+ "/etc/localtime")
File "/tmp/updates/iutil.py", line 105, in copyFile f = os.open(source,
os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/sysimage/usr/share/zoneinfo/US/UTC+01:00'

I really dont know how to go further: I don't have a prior verson of Redhat
Linux, I see no bugfix or workaround to overcome this crash. maybe it's a
commbination of the install features we choose, but which one? I can you tell
mine, if your interested and when it helps to overcome this problem.

To mkothari, who is not very friendly to the Redhat people, I would say: rtfm.
In the installation guide, chapter 3 (Starting the installation), under
paragraph 3.1.1: A note about virtual consoles. This describes the five virtual
consoles, including the installation dialog, visible by pressing Ctrl-Alt-F1.
So Redhat does tell how you can go to the text window.

Best regards from an impatient
Jacques Limpens
(The Netherlands)

Best regards,
Jacques Limpens
Comment 6 Jacques Limpens 2000-01-09 16:58:59 EST
I tried to install Linux 6.1 with the text installer and than the installer goes all right and ends ok. I have now another problem, wich seems to have t do with 1024 cylinders, so i have to re-organize my hard disk first, before I can go any further.
However,this seems worth trying: install  withh the text installer instead of the graphical installation program.
Comment 7 Charles Merriam 2000-01-14 13:53:59 EST
This may be a duplicate of Bug 8360
Comment 8 Steve Welburn 2000-01-22 07:32:59 EST
Using the latest boot image & a new CD-Rom drive, I got round this.

However, I've been very unimpressed with the hassles required to install RedHat
("ease" of installation being the main reason for choosing it over any other
Linux versions) - it's all well & good to recommend downloading the latest boot
images from your website before installation, but it's difficult to do on a
freshly built machine with no operating system... plus an installation program
that gives no decent error messages when it fails.
Comment 9 Jay Turner 2000-02-11 13:20:59 EST
There was a known bug in 6.1 which prevented users from being able to select UTC
offsets in the Time Zone Configuration screen.  This bug is fixed in the latest
installer (available in beta)

Note You need to log in before you can comment on or make changes to this bug.