Bug 55244 - RH7.2 aic7xxx on Intel PR440FX motherboard
RH7.2 aic7xxx on Intel PR440FX motherboard
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 01:50 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 15:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-28 01:50:20 EST
Description of Problem:
When I tried to install RH7.2 on a box with an Intell PR44FX mother board 
it hangs and reports a timeout error in the SCSI bus.  It also incorrectly 
reports the card speed (ie.; 20mbps (fast) as opposed to 40mbps (fast 
ultra)).  

Version-Release number of selected component (if applicable):
RH7.2

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
The motherboard has two intel overdrive PII333 processors.
Comment 1 Need Real Name 2001-10-28 14:57:28 EST
I am having a similar problem with a very similar motherboard.  I have a 
VALinux 1150 (1U server)... user guide: 
http://www.valinux.com/support/products/1150/VA_1150_Uguide.pdf

The Intel motherboard uses the Intel 82443GX+ chipset.  My SCSI card is an 
onboard Adaptec AIC-7896 Dual Channel.
Comment 2 Need Real Name 2001-10-28 15:02:13 EST
To clarify my previous post... the 7.2 install appears to go fine, however upon 
rebooting the computer, after the GRUB page, during all the hardware 
initializations, I get the SCSI error and can't get past it.  It appears to 
recognize my 2 scsi drives, but then I start getting a bunch of scsi timeout 
errors as the OS tries to communicate with all of the 16 scsi IDs.
Comment 3 Need Real Name 2001-10-30 21:36:52 EST
My issue is during the install and not after the install on subsiquent restarts
of the system.  

Any one working on this?  I see that it has been assigned but I have not
recieved a contact.
Comment 4 Joachim Frieben 2001-11-02 13:09:40 EST
I am using an INTEL PR440FX board too, and everything went fine for me (QUANTUM
Atlas IV 9.1 GB, PIONEER DR-U16S, FUJITSU MCE-3064SS). The QUANTUM drive is the
-last- one in the chain and terminates all the 16 data lines!
However, I must confirm, that the QUANTUM drive is -reported- to operate only at
20 MBytes/s. May be it's simply an error in the text output and should rather
read 20 MWords/s (when a word is defined to be 16 bit wide in UW mode):

  Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
  (scsi0:0:0:0) Synchronous at 20.0 Mbyte/sec, offset 15.

The HD is an U2W disk, so in principle, one would expect it to operate at 40.0
Mbytes/s.
Comment 5 Doug Ledford 2001-11-02 13:23:05 EST
To: jfrieben@hotmail.com

NO!  None of the Quantum Atlas IV drives have built in termination (in fact,
*NO* LVD drive has built in termination).  Your speeds are so low because the
SCSI bus can't support going any faster when it's unterminated like yours is. 
Additionally, when the driver says 20MByte/s, it means 20MByte/s, no more.  And,
a U2W drive is good for 80MByte/s when connected to a U2W controller and when
the bus is properly terminated and no Single-Ended devices are placed on the
bus.  If you put even one Single-Ended drive on the same cable as the LVD
drives, then the whole bus is slowed to a maximum speed of 40MByte/s and forced
to operate in Single-Ended instead of LVD mode (which is less reliable and has a
much shorter cable length limit).

To: slm

Your problem is the same as reported in bug #29555.  However, in order to make
your machine work properly after install, you need to either use an SMP kernel
or pass the apic command line option to the UP kernel.  I would suggest going
into the boot loader configuration file (for which ever boot loader your machine
uses) and adding the apic option to the standard kernel parameters that are
passed to the kernels on your machine.  In order to get into the machine after
the install you can manually specify the apic option of course.

To: rchurch

First, the driver reports the speed that it is actually running at in MByte/s,
not MBits/s.  Further, there hasn't been a problem in the speed reporting in
this driver in years.  I would suspect something else is impacting the speed
your drives are reporting, and it is likely the same thing that is causing all
the resets.  I would go through and verify that the SCSI bus is properly cabled
and terminated and that the Adaptec BIOS on your SCSI controller has all of your
drives configured to use the maximum allowed speed.

Note You need to log in before you can comment on or make changes to this bug.