Bug 55246 - USB Keyboard not responding in grub bootup
USB Keyboard not responding in grub bootup
Status: CLOSED DUPLICATE of bug 64684
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 50809 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 02:40 EST by Andreas Bennecke
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 20:24:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Bennecke 2001-10-28 02:40:40 EST
Description of Problem:
The grub bootscreen doesn't accept any input from an USB Keyboard (can't 
select kernel or enter Options). While LILO takes all input correctly

Version-Release number of selected component (if applicable):
grub-0.90-11

How Reproducible:
always

Steps to Reproduce:
1.  Install grub
2.  reboot
3.  try to choose from kernels

Actual Results:
only boots the first kernel in list

Expected Results:
ability to choose the kernel / OS on bootup

Additional Information:
 grub is configured as password protected but wouldn't react on pressing the p 
key either.
Comment 1 Jeremy Katz 2001-10-29 15:00:38 EST
This is odd as GRUB and LILO both apparently use the same BIOS calls to get
keyboard input.  What type of hardware is this on?  (as I haven't seen it on mine)
Comment 2 Andreas Bennecke 2001-10-30 07:35:35 EST
This is on a Fujitsu-Siemens Jetson Computer. i815 Solano (FSC D1189) board 
with a Celeron 700. It4s the standard FSC USB Keyboard attached. 82801AA USB-
Hub. If it helps, the system is profiled as System ID 1000408856 in the RHN.
Comment 3 Mike Gahagan 2001-11-01 11:03:50 EST
I have gotten some support requests indicating this problem also exists on some
HP Pavilion machines.

Tested grub with USB keyboard on an IBM Eserver model X series 200 and it worked
fine.

Tested both Grub and lilo with a USB keyboard on a Dell Precision 420 and the
USB keyboard did not work in either one, nor the BIOS, but it works fine once
linux boots.. so evidently this machine has no bios emulation for USB keyboards.
Comment 4 Andreas Bennecke 2001-11-01 12:04:46 EST
to be more confusing: BIOS works, and LILO prompt works too... so the emulation 
is working as expected, i suppose. is there anything for interrupthandling in 
the grub code, that isn4t in lilo4s? sorry i4m no coder, so i can4t check for 
myself :-(
Comment 5 Need Real Name 2001-11-22 19:25:40 EST
Don't know if this is related or not...

After switching from lilo to grub with RH 7.2, my USB mouse is no longer
recognized by Windows 98. Linux sees the mouse with no problem.  With lilo both
W98 and linux see the mouse.  With grub, if I switch to a PS/2 mouse, both
Windows and linux see the mouse.  The mouse is a Microsoft Optical Wheel Mouse,
and my motherboard is an Intel SE440BX (Phoenix BIOS).
Comment 6 Need Real Name 2002-01-11 23:24:48 EST
I'm having the same problem on a Gateway Performance using a the SUN
UNIX USB keyboard.  LILO works, grub does not.  Keyboard works after USB loaded.

Same thing happens regardless of whether legacy USB support is enabled or
disabled in the BIOS.
Comment 7 Jeremy Katz 2002-01-12 15:08:02 EST
Like I've said, none of my hardware reproduces this...  you might try installing
the updated package at http://people.redhat.com/~katzj/grub/ and then running
`/sbin/grub-install /where/you/installed/grub` (eg /dev/hda) and see if that
makes it work.
Comment 8 Jeremy Katz 2002-01-21 20:24:02 EST
*** Bug 50809 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2002-05-09 14:00:44 EDT

*** This bug has been marked as a duplicate of 64684 ***

Note You need to log in before you can comment on or make changes to this bug.