Bug 55247 - kpackage can't remove packages
kpackage can't remove packages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kpackage (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 02:47 EST by Andreas Bennecke
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 23:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (against kdeadmin-2.2-8.src.rpm's contents) that fixes the problem. (2.32 KB, patch)
2001-11-01 23:52 EST, Carlos Rodrigues
no flags Details | Diff

  None (edit)
Description Andreas Bennecke 2001-10-28 02:47:30 EST
Description of Problem:
after a clean reinstall of 7.2 the kpackage program refuses to remove 
unwanted packages.

Version-Release number of selected component (if applicable):
kdeadmin-2.2-8

How Reproducible:
always

Steps to Reproduce:
1. become root, start kpackage
2. mark old package (old kernel, which should be removable because a new 
one is installed from RHN)
3. press "Uninstall"

Actual Results:
The uninstalldialog tells me: "rpmdepCheck() failed."

Expected Results:
Package should be removed.

Additional Information:
Comment 1 Need Real Name 2001-10-29 04:55:17 EST
i get the "rpmdepCheck() failed." when i try to install anything with kpackage
that is happening on my amd at home and pIII + pii at work

gnorpm works.
command line rpm works
Comment 2 Need Real Name 2001-10-29 04:57:57 EST
oh, i usually bypass that by disabling the dependency check
Comment 3 Need Real Name 2001-10-29 20:34:04 EST
I get similar results as noted above.  Under 7.1 it worked perfectly.
Comment 4 Need Real Name 2001-10-30 20:49:34 EST
I downloaded the latest kdepackage  version 2.2.1-afrom the kdewebsite.  I no
longer get the rpmdepcheck error and so far it seems to work.
Comment 5 Carlos Rodrigues 2001-11-01 23:52:54 EST
Created attachment 36161 [details]
Patch (against kdeadmin-2.2-8.src.rpm's contents) that fixes the problem.
Comment 6 Ngo Than 2001-11-02 15:23:01 EST
kdeadmin-2.2-10 should fix this problem. Thanks for a patch file.
Comment 7 Need Real Name 2001-11-06 14:55:06 EST
I tried the kdeadmin-2.2.1-1.i386.rpm rawhide version and that made did not
fix the problem and I can't seem to find the kdeadmin-2.2-10 anywhere on KDE
or at.rpmfind.net.  Could you put the link up please.  Thanks.
Comment 8 Need Real Name 2001-11-06 16:25:44 EST
I can't seem to figure these patch commands.  What is the command used to 
patch the rpm?  Thanks.
Comment 9 Ngo Than 2001-11-06 17:37:51 EST
you find it on ftp://people.redhat.com/than/7.2

Note You need to log in before you can comment on or make changes to this bug.