Bug 55248 - php truetype support broken in rh7.2
php truetype support broken in rh7.2
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
http://www.buberel.org/weather/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 03:22 EST by jason buberel
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 00:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated spec file for php-4.1.1 (24.41 KB, text/plain)
2002-01-03 20:09 EST, jason buberel
no flags Details
patch file (2.25 KB, patch)
2002-02-28 00:40 EST, jason buberel
no flags Details | Diff

  None (edit)
Description jason buberel 2001-10-28 03:22:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The php 4.0.6 RPM that shipped with rh7.2 does not have truetype font
support compiled/enabled for image generation. The version that shipped
with rh7.1 DID. This has caused quite a few things to brea.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to use php to generate any image file (like PNG) that uses truetype fonts.
	

Actual Results:  The image will fail to generate.

Expected Results:  The image should generate correctly.

Additional info:
Comment 1 jason buberel 2001-11-07 01:50:22 EST
As I have now learned, php-4.0.6 for RH7.2 was compiled with 
truetype font support. However, the php truetype support as 
delivered as part of RH7.2 is still broken, just for other reasons.

The problem has been reported elsewhere 
(http://www.aditus.nu/jpgraph/jpg_faq.php#faq4) and seems to be a 
problem with the combination of:

php4.0.6 + gd 1.8.x + freetype 2.0.x

Other permutations appear to work correctly for some people.

To see the types of error messages that are generated, see the 
following URL:

http://www.buberel.org/weather-devel/combo.php?l=0&sd=7&sm=10&sy=2001&ed=6&em=11&ey=2001&gb=d&tc=h&hc=n&dc=n&pc=n&wc=n&ec=n&cc=n

-jason

Comment 2 jason buberel 2001-12-28 12:59:37 EST
The problem appears to be a missing --configure switch:

--enable-gd-native-ttf

See the following for more details:

http://bugs.php.net/bug.php?id=13983

I've tried to change the php.spec file and rebuild the source RPM, but the 
rebuild always fails with:

checking for DOM support... yes
checking for DOM in default path... not found
configure: error: Please reinstall the libxml >= 2.2.7 distribution
error: Bad exit status from /var/tmp/rpm-tmp.85208 (%build)

..even though I have libxml2 2.4.12 installed.

Grr!

-jason

Comment 3 jason buberel 2002-01-03 20:09:13 EST
Created attachment 41714 [details]
Updated spec file for php-4.1.1
Comment 4 jason buberel 2002-01-03 20:12:14 EST
I just uploaded the specfile that I created (based on the the 4.0.6.rpm spec 
file) using the latest php 4.1.1 sources. I've built and installed these RPMs, 
and they seem to work just fine:

http://www.buberel.org/weather/

You can download the RPMs that were built from this at 
http://www.buberel.org/weather/howto.php#rh72

Please post some new official RPMs so that I can direct my users to them. At 
the very least, this should be updated for rawhide.

-jason
Comment 5 Phil Copeland 2002-02-06 16:19:09 EST
For php-4.1.1 added  in the missing --enable-gd-native-ttf
(been a bit busy with other packages so appologies for any delays)

Hopefully you'll see something new in rawhide tonight to play with

oh, re. DOM, I'm not sure why it can't find it,. can you look though the
config.log to see if it was something daft I'd forgotten? The only other idea
that I have about that is that it's picking up the wrong libxml
	[root@bryce2 SPECS]# rpm -q libxml2
	libxml2-2.4.10-0.7x.2

	[root@bryce2 SPECS]# rpm -q libxml 
	libxml-1.8.14-2

Could you try the updated rpm tonight and give me a yell as to what else broke
or if it actually worked ok for you

Cheers

Phil
=--=

Comment 6 jason buberel 2002-02-28 00:39:22 EST
Had to make a few adjustments:

1. I upgraded to the php-4.1.2 sources in order to get the latest security patch.
2. Inserted a few additional missing ./configure options.

I will upload the spec-file patch in a minute.

-jason
Comment 7 jason buberel 2002-02-28 00:40:59 EST
Created attachment 46880 [details]
patch file
Comment 8 Phil Copeland 2002-06-04 16:04:39 EDT
Upcoming errata in the next few days

Note You need to log in before you can comment on or make changes to this bug.