Bug 55255 - The first graphical login, the panel apears and then disapears
The first graphical login, the panel apears and then disapears
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 09:27 EST by Gary Baribault
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 18:51:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Baribault 2001-10-28 09:27:56 EST
Description of Problem: My HP Omnibook 4150 boots to RL5. The first time I
login to the desktop, the panel apears as normal, the Start Here apears and
then the panel disapears. if I ctrl+bkspace and login again everyting is
fine. I tried the ctrl backspace without the login and then login, but the
panel disapeared again on the first login!


Version-Release number of selected component (if applicable): Downloaded
7.2 ISO with the gnome workstation install. 


How Reproducible: Fails every time on this laptop. Works just fine on a
couple of desktops that I have.


Steps to Reproduce:
1. Boot to run level 5, login.. it fails
2. control+backspace and login again and it's fine
3. 

Actual Results:


Expected Results:


Additional Information:
	
The system has a NVidia video chip, I have the panel set at 1024x765 16M
colors.
Comment 1 Gary Baribault 2001-10-28 09:33:31 EST
I just tried the combination ctrl+bkspace a few more times (after the second
one) and the panel did not disapear again...
Comment 2 Havoc Pennington 2001-10-28 11:49:39 EST
Open panel menu, go to Panel->Global Preferences..., on the Miscellaneous tab,
change the setting to keep panel above other windows, let me know if that fixes
it or not.
Comment 3 Gary Baribault 2001-10-28 15:25:05 EST
No such luck .. I did as suggested and got the same result. I checked that the
change was still in place and it is. Sorry...
Comment 4 Havoc Pennington 2001-10-28 15:47:23 EST
Do you have any problem if you log out normally (choose logout from panel menu)
instead of ctrl-alt-backspacing?
Comment 5 Gary Baribault 2001-10-28 15:50:27 EST
How do I get to the logout option.. I can't get to the panel to open the
system|logout .. The first login does not show the panel. Once I restart X the
panel works, then when I want to shutdown I logout properly.

Gary  B
Comment 6 Havoc Pennington 2001-10-28 15:57:31 EST
Doh, of course, sorry.

Hrm. OK, possible useful info: is the panel gone because it's not running, or
because it's hidden? If you do "ps jaxwww | grep panel" is the panel running?
If it's running, then we can probably blame sawfish for putting the desktop on
top of the panel, and I'm coincidentally working on new sawfish packages you
could try. If it's not running, it might be crashing, and that will be pretty
darn hard to debug unless I can get it to happen on a machine here...
Comment 7 Gary Baribault 2001-10-28 16:26:14 EST
The ps jaxwww|grep panel shows it as being active .. when I startup RL5 for the
first time .. I see it for about a second or two then it vanishes as if it was
in AutoHide... but that feature is not enabled... and when I get back in.. it
does not autohide, so the feature is not active.

Gary B
Comment 8 Gary Baribault 2001-10-28 16:30:57 EST
Hum .. .I just noticed something else, I started the menu with the ctrl-esc keys
and could run programs but all the window 'frames' .. ie the minimize, maximize
and X where missing from all the screens.. sounds like the window manager failed
somehow.. 

Gary B
Comment 9 Paul Jenner 2001-12-20 11:32:53 EST
Out of interest, I had exactly the same symptom when sawfish (or other WM I
guess) was not set to start in my GNOME session but both the panel and nautilus
were.

At login, first the panel is started (and so gets drawn to the screen), then
later nautilus is started and (as it is set to draw the desktop background)
draws over the panel.  Hence the panel is running but is obscured by a nautilus
background.
Comment 10 Havoc Pennington 2002-02-08 18:51:45 EST
See http://bugzilla.gnome.org/show_bug.cgi?id=69333
Comment 11 Havoc Pennington 2002-02-25 18:58:33 EST
This is a duplicate of either the "sawfish puts panel under desktop window" bug
which is fixed, or the "panel crashes on startup" bug which has a million dups
(#55119 I think)

Note You need to log in before you can comment on or make changes to this bug.