Bug 55261 - "neat" ignores value of "no default route"
"neat" ignores value of "no default route"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 13:12 EST by Georg Baumann
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 16:54:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Baumann 2001-10-28 13:12:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
when editing an ISDN connection (ippp0) with "neat", there are
two "Advanced" tabs. The first one has a check box labeled
"Make this connection the default route"; this check box has
no effect on the config file written out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add ISDN device; then close "neat"
2.call "neat" again and edit the ISDN device
3.close "neat" and check the ifcfg-ippp0 file

Additional info:
Comment 1 Ngo Than 2001-10-31 09:31:50 EST
it's strange, that neat shows 2 advanced tabs. i cannot reproduce it here.

could you please start neat from xterm and look if any errors appears?
Comment 2 Georg Baumann 2001-11-06 16:54:45 EST
I have to create a new ISDN-device using neat and then store the changes.
The next time I call neat and click the Edit button with the new device
selected, the following messages are printed out:

Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 448, in on_deviceEditButton_clicked
    button = self.editDevice(device)
  File "/usr/sbin/neat", line 483, in editDevice
    cfg = ISDNDialupDialog(device, self.xml)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/dialupconfig.py",
line 209, in __init__
    DialupDialog.__init__(self, device, xml_main)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/dialupconfig.py",
line 46, in __init__
    device, xml_main)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/deviceconfig.py",
line 78, in __init__
    self.hydrate()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/dialupconfig.py",
line 231, in hydrate
    self.xml.get_widget("dialinNumberEntry").set_text(dialup.Callback.Number)
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2145, in set_text
    _gtk.gtk_entry_set_text(self._o, text)
TypeError: gtk_entry_set_text, argument 2: expected string, None found

I am using redhat-config-network 0.9.1 (RH7.2 fresh installed).

When the second Advanced-Tab is missing my complaint would be:
- cannot suppress modification of default route when using neat
Comment 3 Ngo Than 2001-11-06 17:36:10 EST
please try redhat-config-network-0.9.7-1 on ftp://people.redhat.com/than/7.2. It
should fix this problem

Note You need to log in before you can comment on or make changes to this bug.