Bug 55264 - no chance to not modify default route in ifup-ippp
Summary: no chance to not modify default route in ifup-ippp
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-28 18:29 UTC by Georg Baumann
Modified: 2014-03-17 02:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 19:18:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Georg Baumann 2001-10-28 18:29:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
my ippp0 device connects to our office network; however
I have a DSL connection which I want to use as default
gateway. when using the ifup-ippp for starting and stopping
the ISDN connection, then the default route is always
modified because of:

>     options="$options defaultroute"

my solution, I have changed this to:
<     if [ "$DIALMODE" = "auto" ]; then
<       options="$options -defaultroute"
<     else
<       options="$options defaultroute"
<     fi


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.have a look into /etc/sysconfig/network-scripts/ifup-ippp
2.
3.
	

Additional info:

Comment 1 Bill Nottingham 2002-01-25 05:10:55 UTC
Than, does this make sense? My concern is that this wouldn't do the right thing
for non-dial-on-demand situations where you still want the default route set.

Comment 2 Bill Nottingham 2005-09-29 19:18:01 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.