Bug 552658 - SIGSEGV in "SMBC_parse_path" running /usr/share/system-config-printer/system-config-printer.py
Summary: SIGSEGV in "SMBC_parse_path" running /usr/share/system-config-printer/system-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:85f73de2a15ee3d9873926a2165...
: 546891 547788 553764 554214 554463 556016 556172 556349 557139 557383 557445 557800 567434 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-05 20:16 UTC by Trevor W
Modified: 2010-03-08 12:14 UTC (History)
21 users (show)

Fixed In Version: 3.4.5-0.46.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-26 00:53:54 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (30.69 KB, text/plain)
2010-01-05 20:16 UTC, Trevor W
no flags Details
samba-incorrect-deref.patch (459 bytes, patch)
2010-01-08 11:51 UTC, Tim Waugh
no flags Details | Diff

Description Trevor W 2010-01-05 20:16:10 UTC
abrt 1.0.2 detected a crash.

How to reproduce
-----
1.I was trying to locate a shared network printer on windows xp pc
2.I was searching for //<computer_name> when the crash occured
3.

Attached file: backtrace
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: python
executable: /usr/bin/python
kernel: 2.6.31.9-174.fc12.i686
package: python-2.6.2-2.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)

Comment 1 Trevor W 2010-01-05 20:16:13 UTC
Created attachment 381822 [details]
File: backtrace

Comment 2 Dave Malcolm 2010-01-07 23:13:18 UTC
Thank you for reporting this bug.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What is the output of running the following command?
  rpm -q system-config-printer

Looking at the backtrace, it looks like the problem occurred in thread #1 in SMBC_parse_path

Reassigning component from "python" to "system-config-printer";  hopefully the system-config-printer maintainer will be able to figure this out further or reassign as necessary.

Comment 3 Tim Waugh 2010-01-08 11:49:49 UTC
*** Bug 547788 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2010-01-08 11:49:57 UTC
*** Bug 546891 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2010-01-08 11:50:53 UTC
Looks like a samba bug to me.

Comment 6 Tim Waugh 2010-01-08 11:51:53 UTC
Created attachment 382447 [details]
samba-incorrect-deref.patch

The [] operator binds more tightly than the * operator, so we need parentheses here.

Comment 7 Dave Malcolm 2010-01-08 20:55:19 UTC
*** Bug 553764 has been marked as a duplicate of this bug. ***

Comment 8 Dave Malcolm 2010-01-11 21:27:34 UTC
*** Bug 554214 has been marked as a duplicate of this bug. ***

Comment 9 Tim Waugh 2010-01-12 10:21:50 UTC
*** Bug 554463 has been marked as a duplicate of this bug. ***

Comment 10 Guenther Deschner 2010-01-12 16:25:17 UTC
working on a test to validate fix.

Comment 11 Fedora Update System 2010-01-14 21:16:12 UTC
samba-3.4.4-52.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/samba-3.4.4-52.fc12

Comment 12 Fedora Update System 2010-01-15 22:14:17 UTC
samba-3.4.4-52.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update samba'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0628

Comment 13 Jiri Popelka 2010-01-18 08:31:03 UTC
*** Bug 556349 has been marked as a duplicate of this bug. ***

Comment 14 Jiri Popelka 2010-01-18 08:34:05 UTC
*** Bug 556172 has been marked as a duplicate of this bug. ***

Comment 15 Tim Waugh 2010-01-18 11:50:25 UTC
*** Bug 556016 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2010-01-19 10:24:40 UTC
samba-3.4.5-53.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/samba-3.4.5-53.fc12

Comment 17 Fedora Update System 2010-01-19 19:36:01 UTC
samba-3.4.5-53.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update samba'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0759

Comment 18 Jiri Popelka 2010-01-20 15:11:52 UTC
*** Bug 557139 has been marked as a duplicate of this bug. ***

Comment 19 Jiri Popelka 2010-01-21 09:33:07 UTC
*** Bug 557383 has been marked as a duplicate of this bug. ***

Comment 20 Tim Waugh 2010-01-21 16:18:46 UTC
*** Bug 557445 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2010-01-26 00:53:38 UTC
samba-3.4.5-53.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2010-01-26 01:05:31 UTC
samba-3.4.5-0.46.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Jiri Popelka 2010-03-08 12:14:07 UTC
*** Bug 567434 has been marked as a duplicate of this bug. ***

Comment 24 Jiri Popelka 2010-03-08 12:14:13 UTC
*** Bug 557800 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.