Bug 55267 - boot hangs checking vfat paritions
Summary: boot hangs checking vfat paritions
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dosfstools (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-28 19:55 UTC by Alessandro Pisani
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 20:19:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this fixes the "Warning! FAT32 code is still ALPHA!" message printed on boot (559 bytes, patch)
2001-10-29 07:30 UTC, Alessandro Pisani
no flags Details | Diff

Description Alessandro Pisani 2001-10-28 19:55:22 UTC
I have a vfat entry in my /etc/fstab as follows:
/dev/hda7       /mnt/windisk    vfat     exec,dev,suid,rw 1 1

booting RH 7.2 with this fstab will cause a warning message to appear
during the "Checking filesystems..." phase and then the boot to settle
until CTRL+C is pressed.
The warning message (issued by fsck, called by /etc/rc.d/rc.sysinit) is:
"Warning! FAT32 support is still ALPHA"

The only workaround I found so far is to set the fs_passno field to 0,
as follows:
/dev/hda7       /mnt/windisk    vfat     exec,dev,suid,rw 1 0

disabling fsck for the partition, that is.


All this does NOT happen on RH 7.1 "Seawolf", which i use everyday,
mounting three or four VFAT disks.

Comment 1 Bill Nottingham 2001-10-28 21:05:51 UTC
Bug in dosfstools dosfsck, then.

Comment 2 Alessandro Pisani 2001-10-28 22:14:12 UTC
Fixed: now it works for me.
Steps for fixing:
1: download and install RH 7.2 dosfstools SRPM (v. 2.7)
2: download source .tar.gz of dosfstools v. 2.83: modify .spec file to use 2.8
tar.gz and maintaining RH patches against 2.7 (they will work also with 2.8)
4: rebuild package and install it

Thanks for the hint :>

Comment 3 Alessandro Pisani 2001-10-28 22:18:39 UTC
typo in my last comment: correct version is 2.8 _not_ 2.83
sorry

Comment 4 Alessandro Pisani 2001-10-29 07:30:13 UTC
Created attachment 35361 [details]
this fixes the "Warning! FAT32 code is still ALPHA!" message printed on boot

Comment 5 Bill Nottingham 2006-08-04 20:19:47 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.