Bug 55271 - Seg fault when multiple-part downloads are interrupted
Summary: Seg fault when multiple-part downloads are interrupted
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slrn   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-29 00:11 UTC by mwalton
Modified: 2014-03-17 02:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 23:59:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mwalton 2001-10-29 00:11:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Whe I tag multiple articles, start to download them and then abort the
transfer by hitting CTRL-G, slrn seg faults.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start slrn
2.Enter a binary newgroup with binary posts
3.Tag a bunch of of posts (using the '#' key)
4.Hit the ':' (colon key)
5.Answer Yes to the question 'Save tagged articles?'
6.Accept the suggested temporary file by hitting return
7.Wait for one or two articles to save then hit CTRL-G to abort the
download. slrn often segfaults at this step.
8. Repeat steps 4-7 a couple of times until a segfault occurs

Actual Results:  slrn crashes with the following message:
Segmentation fault (core dumped)

Expected Results:  The download should just abort painlessly with a message
like 'transfer aborted' (i forget what the exact message is)

Additional info:

This bug definitely didn't exist in redhat 7.1

Comment 1 John Gotts 2001-11-09 23:59:30 UTC
The author confirmed to me in e-mail that this bug was fixed in 0.9.7.2.

Changes since 0.9.7.1
[...]
20. Header lines are saved when decoding (again). Hopefully, the uudecode
    routine now handles them correctly. If you have uudeview support
    compiled in, but want to use the builtin code, set use_uudeview to zero.

After a lot of work, I've ported Red Hat 7.2's RPM to slrn 0.9.7.3.  You can get
it at http://linuxsavvy.com/staff/jgotts/slrn-0.9.7.3-1.src.rpm, but please go
easy on the connection as the connection is metered (and costly).

Comment 2 Bill Nottingham 2002-01-25 05:12:03 UTC
0.9.7.3 is in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.