Bug 552717 - Drupal 6 package is needed
Summary: Drupal 6 package is needed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: drupal
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 569833
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-05 22:44 UTC by Kris Buytaert
Modified: 2010-10-29 14:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-29 14:07:36 UTC
Type: ---


Attachments (Terms of Use)
Patch to make drupal6 package (3.47 KB, patch)
2010-02-17 23:27 UTC, Orion Poplawski
no flags Details | Diff

Description Kris Buytaert 2010-01-05 22:44:47 UTC
EPEL still contains Drupal 5, which is kind of obsolete.

Not a single Drupal Site is being build on it today so deploying a webserver with a Drupal package always requires either installing Drupal6 as a tar ball , or using an external repository for Drupal6 rpms.


Drupal 6 , has been out for ages now and Drupal 7 is around the corner.

All (or most of the) relevant Drupal 5 modules have been ported to Drupal 6 in the meanwhile and there are various Drupal code migration tools around to migrate existing Drupal 5 modules to Drupal 6.

Comment 1 Phil Hale 2010-01-07 06:18:51 UTC
I second the motion.  I'm getting some pressure from my clients to get Drupal 6 installed on their systems.  I'd rather keep it in channel than to do a clean install from scratch.

Comment 2 John Calderwood 2010-01-13 18:32:43 UTC
I like to use versions in EPEL whenever possible, but I won't start a new website on a soon to be discontinued Drupal version either.  I imagine 2010 will be when Drupal 5 is discontinued.

Comment 3 Orion Poplawski 2010-02-17 23:27:21 UTC
Created attachment 394845 [details]
Patch to make drupal6 package

Jon - it should be pretty easy to have a parallel installable drupal6 package.  The attached patch pretty much does it I think.  The only difference between the current Fedora devel package would be the name.  Any reason why we can't submit this as an EPEL only package?

Comment 4 Gwyn Ciesla 2010-03-02 14:16:47 UTC
It does.  I'll try to get a review together soon.

Comment 5 Gwyn Ciesla 2010-03-02 14:57:57 UTC
Added review, set it to block this bug.

Comment 6 Mark Chappell 2010-10-13 18:30:12 UTC
drupal6-6.19-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If
problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drupal6'.  You can provide
feedback for this update here:
https://admin.fedoraproject.org/updates/drupal6-6.19-1.el5


Note You need to log in before you can comment on or make changes to this bug.