Bug 55278 - My machine hanga at boot
My machine hanga at boot
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-29 00:37 EST by Tom Diehl
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-05 09:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom Diehl 2001-10-29 00:37:12 EST
Description of Problem:At boot time with the stock 2.4.7-10 kernel the 
machine comes up normally until just after the init acripts returns on on 
enabling swap. It then hangs for about a minute and a half. It then 
continues booting and all is normal. When I upgrade to the 2.4.9-7 kernel 
the machine hangs at the same spot but never comes up. I have waited as 
long as 5 minutes but it stays hung. This is an athlon machine. I tried 
noathlon but no change in the results. Before upgrading to 7.2 I was 
running an ac kernel with the athlon optimizations turned on and I have 
had no problems with the machine.

Version-Release number of selected component (if applicable):
2.4.7-10 and 2.4.9-7

How Reproducible:
Every time I boot.

Steps to Reproduce:
1. Boot the machine and wait. 

Actual Results:
Machine will hang. How long depends on the kernel. See above

Expected Results:
Machine should come up normally.

Additional Information:
 The only thing I can find interesting in the logs is the following:
Oct 29 00:01:16 tigger kernel: hdc: lost interrupt
Oct 29 00:01:16 tigger kernel: hdc: lost interrupt
Oct 29 00:01:16 tigger kernel:   Vendor: HP        Model: CD-Writer+ 9100 
  Rev: 1.0c
Oct 29 00:01:16 tigger kernel:   Type:   CD-ROM                           
  ANSI SCSI revision: 02

The problem Is this is not where the hang is. The logs show nothing when 
it hangs. See below:
Oct 28 23:59:22 tigger rc.sysinit: Checking filesystems succeeded
Oct 28 23:59:23 tigger rc.sysinit: Mounting local filesystems:  succeeded
Oct 28 23:59:23 tigger rc.sysinit: Enabling local filesystem quotas:  
Oct 28 23:59:23 tigger rc.sysinit: Enabling swap space:  succeeded
Oct 29 00:01:01 tigger init: Entering runlevel: 5

It hangs right here!

Oct 29 00:01:01 tigger kudzu: Updating /etc/fstab succeeded
Oct 29 00:01:12 tigger kudzu:  succeeded
Comment 1 Arjan van de Ven 2001-10-29 04:02:30 EST
can you please try adding "ide=nodma" to the kernel command line ?
in lilo this can be done by typing "linux ide=nodma"
in grub you need to type "e", then go to the second line, edit that and add
ide=nodma to the end of that line, and then press enter, and "b" for booting
into that kernel.
Comment 2 Tom Diehl 2001-10-29 10:18:47 EST
Tried booting with ide=nodma as you requested. There is no change I still get 
the lost interrupt errors and the hangs on both kernels.
Comment 3 Tom Diehl 2001-10-29 13:32:43 EST
I did a little more debugging on this. I added echo statments to rc.sysinit to 
see where it is hanging. That revealed that it was hanging trying to load the 
ide-scsi modules. I thought that maybe the cause of the hang is/was the lost 
interrupts on hdc. So I moved the 2 cdroms to  hdg and hdh which is an hpt 3xx 
controller (not exactly sure which one. It is the one that does udma100 with 
raid). Now the machine boots both kernels without a problem. Moving the cdrom 
drives back to the via i(hdc and hde) controller reproduces the problem. FWIW 
this machine ran fine with the ac kernels seawolf and the cd drives on hdc and 
hde. I did not have this problem until after the upgrade. I would like to 
track this down some more if you have any ideas. I cannot program but I have 
no problem recompiling or reconfiguring the system (short of formatting the 
disks this is my personal workstation). Please let me know and thanks for the 
Comment 4 Tom Diehl 2004-02-05 09:35:16 EST
I do not think this is valid any longer.

Note You need to log in before you can comment on or make changes to this bug.