Bug 55281 - [emu10k] "SBLive mp3+ 5.1" distorts sound in 2.4.9
[emu10k] "SBLive mp3+ 5.1" distorts sound in 2.4.9
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 01:07 EST by Alejandro Gonzalez Hernandez - Imoq
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 15:55:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alejandro Gonzalez Hernandez - Imoq 2001-10-29 01:07:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
After I upgraded to kernel 2.7.9-7 (+ all errata) the sounds made by the
"play" command are just very disturbing noise. This is with a Soundblaster
Live! mp3+ 5.1 soundcard.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. find a .wav file
2. type "play file.wav"
3. hear the noise.
	

Actual Results:  Horrible noise.


Expected Results:  The nice "oh-ooooh" from licq, or any other noise.


Additional info:

The problem seemed to came with kernel 2.4.9-7, since I was using the stock
kernel for Enigma, or the 2.4.9-6 that was released a little before, and I
didn't have that problem. On a side note, playing music with xmms works
very fine, it's just the "play" command that licq uses, but I haven't done
any extensive research yet.

Anyway, here are the relevant files:

[imoq@home imoq]$ cat /etc/modules.conf
alias eth0 8139too
alias eth1 3c59x
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null
2>&1 || :
[imoq@home imoq]$

from /var/log/dmesg:

Creative EMU10K1 PCI Audio Driver, version 0.7, 13:55:05 Oct 18 2001
PCI: Found IRQ 10 for device 00:09.0
emu10k1: EMU10K1 rev 7 model 0x8061 found, IO at 0xdc00-0xdc1f, IRQ 10

from /var/log/messages:

Oct 28 19:39:21 home modprobe: modprobe: Can't locate module sound-slot-1
Oct 28 19:39:21 home modprobe: modprobe: Can't locate module sound-service-1-0
Oct 28 19:39:21 home modprobe: modprobe: Can't locate module sound-slot-1
Oct 28 19:39:21 home modprobe: modprobe: Can't locate module sound-service-1-0

and finally,

[root@home root]# lsmod
Module                  Size  Used by
sr_mod                 15448   1  (autoclean)
emu10k1                49668   2  (autoclean)
soundcore               4452   4  (autoclean) [emu10k1]
tdfx                   34040   1
agpgart                27456   0  (unused)
binfmt_misc             6436   1
vmnet                  20672   2
vmmon                  18996   6
3c59x                  26504   1
8139too                13120   1
ipchains               39368   0
ide-scsi                8288   1
scsi_mod               98456   2  [sr_mod ide-scsi]
ide-cd                 27072   0
cdrom                  28576   0  [sr_mod ide-cd]
nls_iso8859-1           2816   1  (autoclean)
nls_cp437               4320   1  (autoclean)
vfat                   10332   1  (autoclean)
fat                    32984   0  (autoclean) [vfat]
mousedev                4416   2
hid                    19040   0  (unused)
input                   3840   0  [mousedev hid]
usb-uhci               21668   0  (unused)
usbcore                51808   1  [hid usb-uhci]
ext3  62400   6
jbd                    41060   6  [ext3]
[root@home root]#

oh, I almost forgot:

[root@home root]# uname -a
Linux home.imoqland.com 2.4.9-7 #1 Thu Oct 18 13:47:25 EDT 2001 i686 unknown
[root@home root]#
Comment 1 Bryce Nesbitt 2002-03-22 14:16:12 EST
I have similar problems

 HardHat:audio> cat /etc/modules.conf
 alias sound-slot-0 emu10k1

 HardHat:audio> uname -a
 Linux HardHat 2.4.9-21 #1 Thu Jan 17 13:35:37 EST 2002 i686 unknown
 HardHat:bryce> cat /proc/cpuinfo 
 processor       : 0
 vendor_id       : AuthenticAMD
 cpu family      : 6
 model           : 3
 model name      : AMD Duron(tm) Processor
 stepping        : 1
 cpu MHz         : 908.101
 cache size      : 64 KB
 fdiv_bug        : no
 hlt_bug         : no
 f00f_bug        : no
 coma_bug        : no
 fpu             : yes
 fpu_exception   : yes
 cpuid level     : 1
 wp              : yes
 flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
 pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow
 bogomips        : 1808.79

 Since upgrading to Kernel 2.4.9-13 I've had huge audio problems.  100% of the
 time I get very bad  glitches when sound is used after a quiet period. 
Sometimes audio plays back
 fine after the glitch, sometimes I get terrible noise instead of audio.

Note You need to log in before you can comment on or make changes to this bug.