Bug 552972 - actionpack 2.3.4 broken with rack 1.1.0
Summary: actionpack 2.3.4 broken with rack 1.1.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-actionpack
Version: 12
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 530193 543549
TreeView+ depends on / blocked
 
Reported: 2010-01-06 17:40 UTC by Mamoru TASAKA
Modified: 2010-03-12 04:25 UTC (History)
7 users (show)

Fixed In Version: rubygem-rack-1.0.0-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-12 04:25:45 UTC
Type: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2010-01-06 17:40:55 UTC
Description of problem:
Well, on rawhide rack was updated to 1.1.0 recently, however

[tasaka1@localhost ~]$ irb
irb(main):001:0> require "rubygems"
=> true
irb(main):002:0> gem "actionpack"
Gem::LoadError: RubyGem version error: rack(1.1.0 not ~> 1.0.0)

        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:827:in `report_activate_error'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:261:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:296:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `each'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:68:in `gem'
        from (irb):2
        from :0

Even after I changed rack dependency from "~> 1.0.0" to ">= 1.0.0"
in Rakefile and lib/action_controller.rb in actionpack 2.3.4 gem,
"$ rake test" for actionpack now fails with

2358 tests, 10700 assertions, 7 failures, 70 errors
rake aborted!

Version-Release number of selected component (if applicable):
rubygem-actionpack-2.3.4-3.fc12.noarch
rubygem-rack-1.1.0-1.fc13.noarch

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.

Comment 1 Mamoru TASAKA 2010-01-07 15:20:41 UTC
Well, applied a workaround on rubygem-actionpack-2.3.4-4.fc13
If you find some bugs and have solution for them, please feel
free to modify this, thank you.

Comment 2 Mamoru TASAKA 2010-01-21 17:19:43 UTC
Once closing.

Comment 3 Thomas von Steiger 2010-02-24 22:33:47 UTC
Hi, i found the same problem in rubygem-actionpack-2.3.4-3.fc12

workspace]$ rails test
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:827:in `report_activate_error': RubyGem version error: rack(1.1.0 not ~> 1.0.0) (Gem::LoadError)
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:261:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:296:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `each'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:296:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `each'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:295:in `activate'
	from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:68:in `gem'
	from /usr/bin/rails:18

With workaround in /usr/lib/ruby/gems/1.8/specifications/actionpack-2.3.4.gemspec

from:
"s.add_dependency(%q<rack>, ["~> 1.0.0"])"
to:
"s.add_dependency(%q<rack>, [">= 1.0.0"])"

and:

cd /usr/lib/ruby/gems/1.8/gems/actionpack-2.3.4
 gem build ../../specifications/actionpack-2.3.4.gemspec 
WARNING:  deprecated autorequire specified
  Successfully built RubyGem
  Name: actionpack
  Version: 2.3.4
  File: actionpack-2.3.4.gem

gem install actionpack-2.3.4.gem 
Successfully installed actionpack-2.3.4
1 gem installed
Installing ri documentation for actionpack-2.3.4...
Installing RDoc documentation for actionpack-2.3.4...

workspace]$ rails test
      create  
      create  app/controllers
      create  app/helpers
      create  app/models
      create  app/views/layouts
      ...

Are we get a new version for f12?
Thank you,
Thomas

Comment 4 David Lutterkort 2010-02-25 00:01:03 UTC
This is on F12, right ? The issue to me is that rack should have never been updated to 1.1.0 in F12. Any chance we can downgrade it again ?

Comment 5 Mamoru TASAKA 2010-02-25 05:23:00 UTC
Reopening for F-12.

(In reply to comment #4)
> This is on F12, right ? The issue to me is that rack should have never been
> updated to 1.1.0 in F12. Any chance we can downgrade it again ?    

Introducing Epoch?

Comment 6 Thomas von Steiger 2010-02-25 05:49:01 UTC
Yes, F12.

Comment 7 Jeroen van Meeuwen 2010-02-25 11:57:57 UTC
(In reply to comment #5)
> Reopening for F-12.
> 
> (In reply to comment #4)
> > This is on F12, right ? The issue to me is that rack should have never been
> > updated to 1.1.0 in F12. Any chance we can downgrade it again ?    
> 
> Introducing Epoch?    

+1

Comment 8 Mamoru TASAKA 2010-03-03 05:41:30 UTC
So as kanarip agreed to downgrade rack to 1.0.0 on F-12, can
we do action now?

Comment 9 Michal Babej 2010-03-10 13:07:12 UTC
Hello,

please downgrade rack; rubygem-haml can't build in F12 until this is fixed. 

Thanks

Comment 10 Michal Fojtik 2010-03-10 16:04:33 UTC
Hi,

There are also other gems/tests which actually failing due to rack-1.1.0. 
I'm voting for downgrade.

Michal

Comment 11 Fedora Update System 2010-03-10 16:17:30 UTC
rubygem-rack-1.0.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rubygem-rack-1.0.0-3.fc12

Comment 12 Fedora Update System 2010-03-12 04:25:40 UTC
rubygem-rack-1.0.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.