Bug 553347 - Call to progress.hide() crashes program when no yum history in use
Summary: Call to progress.hide() crashes program when no yum history in use
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-07 17:01 UTC by Jani Savuoja
Modified: 2010-02-02 20:43 UTC (History)
1 user (show)

Fixed In Version: 2.9.6-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-02 20:43:17 UTC


Attachments (Terms of Use)
Suggested fix: move the progress.hide() call inside block above (970 bytes, patch)
2010-01-07 17:01 UTC, Jani Savuoja
no flags Details | Diff

Description Jani Savuoja 2010-01-07 17:01:21 UTC
Created attachment 382285 [details]
Suggested fix: move the progress.hide() call inside block above

Description of problem:
Application crashes when there's no yum history in use. This is caused by a method call in wrong scope: the object in question hasn't been created if there's no yum history enabled.

Version-Release number of selected component (if applicable):
2.9.5-1.fc11

How reproducible:
Run yumex without yum history functionality. The program terminates after package lists have been generated.

Steps to Reproduce:
1. See above
  
Actual results:
Crash with Python stack trace:
Traceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 52, in <module>
    app.run()
  File "/usr/lib/python2.6/site-packages/yumexgui/__init__.py", line 631, in run
    self.setup_gui()
  File "/usr/lib/python2.6/site-packages/yumexgui/__init__.py", line 802, in setup_gui
    self.setup_history(limit=self.settings.history_limit)
  File "/usr/lib/python2.6/site-packages/yumexgui/__init__.py", line 1079, in setup_history
    progress.hide()
UnboundLocalError: local variable 'progress' referenced before assignment

Expected results:
No crash

Additional info:

Comment 1 Tim Lauridsen 2010-01-07 18:07:59 UTC
Thanks, for reporting, i have fixed it upstream

Comment 2 Fedora Update System 2010-01-14 01:21:42 UTC
yumex-2.9.6-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0507

Comment 3 Fedora Update System 2010-02-02 20:43:02 UTC
yumex-2.9.6-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.