This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 553385 - Failure trying to set configuration parameters on Postfix child resource "Access File"
Failure trying to set configuration parameters on Postfix child resource "Acc...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.4
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Jeff Weiss
: SubBug
Depends On:
Blocks: RHQ_Config rhq_triage
  Show dependency treegraph
 
Reported: 2010-01-07 14:12 EST by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL5.3, git hash 9adb2903b6f19aaaf09c4b837acaf574409ff998 (on rhq-linux-config branch)
Last Closed: 2014-05-23 16:50:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My existing /etc/postfix/access file (17.41 KB, application/octet-stream)
2010-01-07 14:13 EST, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2010-01-07 14:12:11 EST
Description of problem:
Looks to be an augeas related problem trying to save a config change to postfix's access file.  

Version-Release number of selected component (if applicable):
[jonqa@jweiss-rhel3 bin]$ rpm -q augeas
augeas-0.6.0-2.el5


How reproducible:
Always (with this environment)

Steps to Reproduce:
1. Take postfix server into inventory
2. Navigate to Postfix server's "Access File" child.
3. Edit the configuration, add a new property set, the 3 fields set to: 
"Ip address 1.2.3"
"ACCEPT" 	
[not set]
4. Save the configuration

Actual results:
The configuration update fails.  Clicking on the "Failure" link shows (after unescaping the bad encoding):

> java.lang.RuntimeException: File "/etc/postfix/access/error/path":/files/etc/postfix/access/00File "/etc/postfix/access/error/lens":/usr/share/augeas/lenses/dist/postfix_access.aug:22.17-25.70:File "/etc/postfix/access/error/message":Failed to match     { /pattern/ = /[^-
>  #] / }{ /action/ = /[^-
>  #] / }{ /parameters/ = /[^-
>  #]|[^-
>  #]([^-
> #]|
> [     ] )*[^-
>  #]/ }?  with tree    { "pattern" = "Ip address 1.2.3" } { "action" = "ACCEPT" }at org.rhq.plugins.augeas.AugeasConfigurationComponent.saveConfigurationFiles(AugeasConfigurationComponent.java:615)at org.rhq.plugins.augeas.AugeasConfigurationComponent.updateResourceConfiguration(AugeasConfigurationComponent.java:179)at sun.reflect.GeneratedMethodAccessor87.invoke(Unknown Source)at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)at java.lang.reflect.Method.invoke(Method.java:616)at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:525)at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)at java.util.concurrent.FutureTask.run(FutureTask.java:166)at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)at java.lang.Thread.run(Thread.java:636)Caused by: net.augeas.AugeasException: save failedat net.augeas.Augeas.processLastCall(Augeas.java:396)at net.augeas.Augeas.save(Augeas.java:338)at org.rhq.plugins.augeas.AugeasConfigurationComponent.saveConfigurationFiles(AugeasConfigurationComponent.java:613)... 10 more



Expected results:
Configuration update completes successfully.

Additional info:
See RHQ-665 for the bug on error message text encoding problem.
Comment 1 Jeff Weiss 2010-01-07 14:13:04 EST
Created attachment 382313 [details]
My existing /etc/postfix/access file
Comment 2 wes hayutin 2010-02-16 11:54:37 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:00:04 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Corey Welton 2010-10-05 09:08:18 EDT
Lowering severity/priority - not an enterprise plugin

Note You need to log in before you can comment on or make changes to this bug.