Bug 55340 - Removal of vixie-cron
Summary: Removal of vixie-cron
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-29 22:15 UTC by Matthew Galgoci
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 14:16:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Galgoci 2001-10-29 22:15:29 UTC
Removal of vixie-cron in Red Hat Linux 7.2 (and probably earlier) fails
if cron is not first running. The preun script looks like this:

if [ $1 = 0 ]; then
    /sbin/chkconfig --del crond
    /sbin/service crond stop >/dev/null 2>&1
fi

It should be more like the following:

if [ "$1" = 0 ]
then
	/sbin/service crond stop > /dev/null 2>&1 || :
	/sbin/chkconfig --del crond
fi

Comment 1 Michael Schwendt 2001-11-01 15:50:00 UTC
In similar bug reports about other components, I've suggested a fix like this:

[ -f /var/lock/subsys/crond ] && /sbin/service crond stop >/dev/null 2>&1


Comment 2 Bill Huang 2002-06-10 08:14:34 UTC
Fixed in rawhide.Thanks for your advice.


Note You need to log in before you can comment on or make changes to this bug.